CVE-2026-76816 Netty: MQTT Topic Name and Client ID Validation Bypass

Low 3.5 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2026-76816?

CVE-2026-76816 is a low-severity vulnerability in netty, published on 24 Aug 2026.

Official description

Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.137.Final and 4.2.17.Final, MqttEncoder does not validate client identifiers, will topics, usernames, and PUBLISH topic names before encoding, allowing prohibited null bytes in MQTT UTF-8 string fields and potentially causing routing, access-control, or identity mismatches in downstream brokers. The vulnerability is exploitable when an application uses Netty's MQTT encoder to construct messages from user-controlled input. This issue is fixed in versions 4.1.137.Final and 4.2.17.Final.

Weakness: CWE-626, CWE-20

Which versions are affected by CVE-2026-76816?

How do I fix CVE-2026-76816?

Upgrade to a fixed version.

Is CVE-2026-76816 being exploited?

There is no known exploitation of CVE-2026-76816 in the wild and no public exploit code.

Sources

Also known as CLEANSTART-2026-GV10052, DEBIAN-CVE-2026-76816, GHSA-43fm-7cxg-hf3j, UBUNTU-CVE-2026-76816.

Is CVE-2026-76816 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free