# CVE-2026-76816: Netty: MQTT Topic Name and Client ID Validation Bypass


- **Severity:** Low 3.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 24 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** CLEANSTART-2026-GV10052, DEBIAN-CVE-2026-76816, GHSA-43fm-7cxg-hf3j, UBUNTU-CVE-2026-76816

## What is CVE-2026-76816?

CVE-2026-76816 is a low-severity vulnerability in netty, published on 24 Aug 2026. 

### Official description

Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.137.Final and 4.2.17.Final, MqttEncoder does not validate client identifiers, will topics, usernames, and PUBLISH topic names before encoding, allowing prohibited null bytes in MQTT UTF-8 string fields and potentially causing routing, access-control, or identity mismatches in downstream brokers. The vulnerability is exploitable when an application uses Netty's MQTT encoder to construct messages from user-controlled input. This issue is fixed in versions 4.1.137.Final and 4.2.17.Final.

Weakness: CWE-626 (Null Byte Interaction Error (Poison Null Byte)), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-76816?


## How do I fix CVE-2026-76816?

Upgrade to a fixed version.

## Is CVE-2026-76816 being exploited?

There is no known exploitation of CVE-2026-76816 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-76816 and fix it if it is affected.

What it is: CVE-2026-76816 is a low-severity vulnerability in netty, published on 24 Aug 2026. 
Exploitation: There is no known exploitation of CVE-2026-76816 in the wild and no public exploit code.

Affected product: netty. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-76816/ (Markdown: https://insights.sbomify.com/CVE-2026-76816/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-76816
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-76816
- OSV: https://osv.dev/vulnerability/CVE-2026-76816

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-76816/
Summaries are generated and may contain mistakes; the official description above is the record.
