# CVE-2026-76820: OpenCTI: Synchronizer SSRF: stream fetch has no URL validation

> Authenticated users can exploit missing URL validation in the synchronizer to access internal services and cloud metadata, enabling network scanning and data disclosure.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** GHSA-f6pj-3m32-q934

## What is CVE-2026-76820?

CVE-2026-76820 is a high-severity server-side request forgery vulnerability in OpenCTI-Platform opencti, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenCTI is an open source platform for managing cyber threat intelligence knowledge and observables. Prior to 7.260701.0, the synchronizerFetch GraphQL query called fetchRemoteStreams after checking only that a remote stream URL used HTTP or HTTPS. The backend did not apply the ingestion deny list or reject private, loopback, and link-local destinations, allowing an authenticated account with the INGESTION capability to make OpenCTI request internal services and cloud metadata endpoints. Returned connection errors could distinguish open HTTP ports, open non-HTTP ports, and closed ports, enabling internal network scanning, while compatible endpoint responses could disclose internal data. This issue is fixed in version 7.260701.0.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-76820?


## How do I fix CVE-2026-76820?

No fix has been published for CVE-2026-76820 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-76820 being exploited?

There is no known exploitation of CVE-2026-76820 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-76820 and fix it if it is affected.

What it is: CVE-2026-76820 is a high-severity server-side request forgery vulnerability in OpenCTI-Platform opencti, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-76820 in the wild and no public exploit code.

Affected product: OpenCTI-Platform opencti. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-76820/ (Markdown: https://insights.sbomify.com/CVE-2026-76820/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-76820
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-76820
- OSV: https://osv.dev/vulnerability/CVE-2026-76820

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-76820/
Summaries are generated and may contain mistakes; the official description above is the record.
