# CVE-2026-76821: OpenCTI: User-Controlled ReDoS in JSON Ingestion Mapper

> An authenticated user can cause a denial of service in OpenCTI by submitting a malicious regular expression in the JSON ingestion mapper.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** GHSA-7g3x-wc2m-9h9x

## What is CVE-2026-76821?

CVE-2026-76821 is a high-severity denial of service vulnerability in OpenCTI-Platform opencti, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenCTI is an open source platform for managing cyber threat intelligence knowledge and observables. Prior to 7.260706.0, the JSON ingestion mapper's extractWithRegexp formula function compiled a user-supplied regular expression with the JavaScript RegExp engine in opencti-platform/opencti-graphql/src/parser/json-mapper.ts without validating its complexity. An authenticated user with JSON mapper creation permission could provide a catastrophically backtracking pattern and matching ingestion input, blocking the Node.js event loop and making the GraphQL API unavailable to all users. Scheduled ingestion could repeatedly execute the malicious mapper without additional attacker action, and recovery could require disabling the mapper and restarting the process. The issue affects availability and does not expose or modify data. This issue is fixed in version 7.260706.0.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-76821?


## How do I fix CVE-2026-76821?

No fix has been published for CVE-2026-76821 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-76821 being exploited?

There is no known exploitation of CVE-2026-76821 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-76821 and fix it if it is affected.

What it is: CVE-2026-76821 is a high-severity denial of service vulnerability in OpenCTI-Platform opencti, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-76821 in the wild and no public exploit code.

Affected product: OpenCTI-Platform opencti. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-76821/ (Markdown: https://insights.sbomify.com/CVE-2026-76821/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-76821
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-76821
- OSV: https://osv.dev/vulnerability/CVE-2026-76821

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-76821/
Summaries are generated and may contain mistakes; the official description above is the record.
