# CVE-2026-76901: Missing authorization in CordysCRM

> Authenticated users can access arbitrary leads and accounts belonging to other users due to missing object-level authorization checks.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Sep 2026
- **Updated:** 21 Sep 2026
- **Also known as:** GHSA-hxp2-5w5p-2grq

## What is CVE-2026-76901?

CVE-2026-76901 is a medium-severity missing authorization vulnerability in 1Panel-dev CordysCRM, published on 18 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

CordysCRM is an open source AI-powered customer relationship management system that supports private deployment. Prior to 1.7.4, GET /pool/lead/get/{id} in PoolClueController.get and GET /pool/account/get/{id} in PoolCustomerController.get use bare pool-read permission checks without the CsPermission resourceId binding that enforces per-record data scope. An authenticated user with the ordinary CLUE_MANAGEMENT_POOL:READ or CUSTOMER_MANAGEMENT_POOL:READ permission can supply another record's id and cause unscoped primary-key getters to return leads or accounts owned by other users, departments, or organizations. Exposed data includes contact names, phone numbers, owner and department attribution, and custom field values. This issue is fixed in version 1.7.4.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-76901?


## How do I fix CVE-2026-76901?

No fix has been published for CVE-2026-76901 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-76901 being exploited?

There is no known exploitation of CVE-2026-76901 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-76901 and fix it if it is affected.

What it is: CVE-2026-76901 is a medium-severity missing authorization vulnerability in 1Panel-dev CordysCRM, published on 18 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-76901 in the wild and no public exploit code.

Affected product: 1Panel-dev CordysCRM. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-76901/ (Markdown: https://insights.sbomify.com/CVE-2026-76901/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-76901
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-76901
- OSV: https://osv.dev/vulnerability/CVE-2026-76901

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-76901/
Summaries are generated and may contain mistakes; the official description above is the record.
