CVE-2026-76905 kin-openapi openai3filter: nil-pointer panic in ConvertErrors on malformed multipart/form-data body enables unauthenticated DoS

High 7.5 Published Updated

Unauthenticated attackers can cause a denial of service via a nil-pointer panic in kin-openapi when processing malformed multipart/form-data requests.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-76905?

CVE-2026-76905 is a high-severity vulnerability in getkin kin-openapi, published on 21 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

kin-openapi is a Go project for handling OpenAPI files. From 0.10.0 until 0.141.0, openapi3filter.convertParseError in openapi3filter/validation_error_encoder.go dereferences e.Parameter.In without checking whether e.Parameter is nil. A malformed non-string scalar field in a multipart/form-data request body produces a nested ParseError with a nil RequestError.Parameter, and applications that render the validation error through openapi3filter.ConvertErrors or ValidationErrorEncoder panic. An unauthenticated client can repeatedly send such requests to deny service when the application lacks a recovery boundary. JSON request bodies and applications that do not use these error-rendering helpers are not affected. This issue is fixed in version 0.141.0.

Weakness: CWE-476

Which versions are affected by CVE-2026-76905?

3 open source packages ship an affected version, including github.com/getkin/kin-openapi.

PackageAffectedFixed in
github.com/getkin/kin-openapi GoFrom 0.10.00.141.0
github.com/getkin/kin-openapi GoFrom 0.10.00.141.0
github.com/getkin/kin-openapi GoFrom 0.10.00.141.0

How do I fix CVE-2026-76905?

Upgrade github.com/getkin/kin-openapi to 0.141.0 or later.

Is CVE-2026-76905 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-76905 exists.

Sources

Also known as DEBIAN-CVE-2026-76905, GHSA-mmfr-pmjx-hw9w, GO-2026-6274, MINI-3344-88gm-6mcc, MINI-3446-q988-7h93, MINI-3c5f-xpmm-9wxq and 41 more.

Is CVE-2026-76905 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free