# CVE-2026-76905: kin-openapi openai3filter: nil-pointer panic in ConvertErrors on malformed multipart/form-data body enables unauthenticated DoS

> Unauthenticated attackers can cause a denial of service via a nil-pointer panic in kin-openapi when processing malformed multipart/form-data requests.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-76905, GHSA-mmfr-pmjx-hw9w, GO-2026-6274, MINI-3344-88gm-6mcc, MINI-3446-q988-7h93, MINI-3c5f-xpmm-9wxq, MINI-47w4-qqf2-vq67, MINI-49wg-x5cp-pf43, MINI-4jvx-6gr5-pf56, MINI-56c3-mw5h-gc8w, MINI-5v7f-m3h6-h78v, MINI-6mvq-4p92-2jwh, MINI-6r9x-fjqh-4pc7, MINI-6rr5-qwfj-8gp7, MINI-728j-j2mp-mwmp, MINI-775h-8xr8-vqvc, MINI-7fxv-fmmr-rf25, MINI-7jqp-wr5x-6r57, MINI-8rm4-fmmx-7m6x, MINI-95rq-f375-jvxf, MINI-9g89-3m59-wh5w, MINI-9rr4-4pff-9gf7, MINI-c6pf-xfpx-pxjf, MINI-f48c-967w-xjp4, MINI-f9r2-crvp-q7f2, MINI-fc8h-4gq5-q35c, MINI-gjh7-h8ww-3hc5, MINI-h5xg-xwjx-hw76, MINI-hpwf-hjvc-3v78, MINI-hw7f-548c-87jx, MINI-j9m2-f72j-jp33, MINI-jgc5-wx3m-p39h, MINI-jrwv-rvm3-fwcw, MINI-mgq2-2w2v-78gg, MINI-p28g-mqh9-c6gp, MINI-prhm-v234-5993, MINI-pvwj-9j3v-p44q, MINI-pxf3-cw3f-rgpj, MINI-q272-7r9h-hp84, MINI-qj6h-2vjx-6c78, MINI-r276-6vqm-xjwj, MINI-rjwx-fr3p-hm5w, MINI-v9rm-376v-2v9p, MINI-w8qr-49mp-4jvh, MINI-wc8r-45wp-5qjp, MINI-x26p-xx9g-7774, UBUNTU-CVE-2026-76905

## What is CVE-2026-76905?

CVE-2026-76905 is a high-severity vulnerability in getkin kin-openapi, published on 21 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

kin-openapi is a Go project for handling OpenAPI files. From 0.10.0 until 0.141.0, openapi3filter.convertParseError in openapi3filter/validation_error_encoder.go dereferences e.Parameter.In without checking whether e.Parameter is nil. A malformed non-string scalar field in a multipart/form-data request body produces a nested ParseError with a nil RequestError.Parameter, and applications that render the validation error through openapi3filter.ConvertErrors or ValidationErrorEncoder panic. An unauthenticated client can repeatedly send such requests to deny service when the application lacks a recovery boundary. JSON request bodies and applications that do not use these error-rendering helpers are not affected. This issue is fixed in version 0.141.0.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2026-76905?

3 open source packages ship an affected version, including github.com/getkin/kin-openapi.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/getkin/kin-openapi` | Go | From 0.10.0 | 0.141.0 |
| `github.com/getkin/kin-openapi` | Go | From 0.10.0 | 0.141.0 |
| `github.com/getkin/kin-openapi` | Go | From 0.10.0 | 0.141.0 |

## How do I fix CVE-2026-76905?

Upgrade github.com/getkin/kin-openapi to 0.141.0 or later.

## Is CVE-2026-76905 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-76905 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-76905 and fix it if it is affected.

What it is: CVE-2026-76905 is a high-severity vulnerability in getkin kin-openapi, published on 21 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-76905 exists.

Affected packages and fixed versions:
- github.com/getkin/kin-openapi (Go): affected from 0.10.0; fixed in 0.141.0
- github.com/getkin/kin-openapi (Go): affected from 0.10.0; fixed in 0.141.0
- github.com/getkin/kin-openapi (Go): affected from 0.10.0; fixed in 0.141.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-76905/ (Markdown: https://insights.sbomify.com/CVE-2026-76905/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-76905
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-76905
- OSV: https://osv.dev/vulnerability/CVE-2026-76905

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-76905/
Summaries are generated and may contain mistakes; the official description above is the record.
