# CVE-2026-76909: Unleash: CR-approval email renders user-controlled raw HTML

> Attackers can inject HTML into approval emails, enabling phishing or tracking, affecting Unleash users with email notifications enabled.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Sep 2026
- **Updated:** 23 Sep 2026
- **Also known as:** GHSA-7hvx-28gp-mf6j, MINI-37xr-34vh-v5cg

## What is CVE-2026-76909?

CVE-2026-76909 is a low-severity cross-site scripting vulnerability in unleash, published on 22 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Unleash is an open-source feature management platform. Prior to 8.0.3, the change-request approval email template at src/mailtemplates/requested-cr-approval/requested-cr-approval.html.mustache renders the user-controlled changeRequestTitle, requesterName, and requesterEmail values without HTML escaping, and sendRequestedCRApprovalEmail passes those values to Mustache rendering. A project member who can create a change request when approval emails are enabled can inject HTML into an approver's notification, allowing forged links, tracking content, or visually altered email content. This issue is fixed in version 8.0.3.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-76909?

2 open source packages ship an affected version, including unleash-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `unleash-server` | npm | All versions | 8.0.3 |
| `unleash-server` | npm | All versions | 8.0.3 |

## How do I fix CVE-2026-76909?

Upgrade unleash-server to 8.0.3 or later.

## Is CVE-2026-76909 being exploited?

There is no known exploitation of CVE-2026-76909 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-76909 and fix it if it is affected.

What it is: CVE-2026-76909 is a low-severity cross-site scripting vulnerability in unleash, published on 22 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-76909 in the wild and no public exploit code.

Affected packages and fixed versions:
- unleash-server (npm): affected all versions; fixed in 8.0.3
- unleash-server (npm): affected all versions; fixed in 8.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-76909/ (Markdown: https://insights.sbomify.com/CVE-2026-76909/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-76909
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-76909
- OSV: https://osv.dev/vulnerability/CVE-2026-76909

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-76909/
Summaries are generated and may contain mistakes; the official description above is the record.
