CVE-2026-76982 Apache Wicket: XSS in Button via its model object
Cross-site scripting vulnerability in Apache Wicket allows attackers to inject scripts via button model objects rendered in button elements.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2026-76982?
CVE-2026-76982 is a medium-severity cross-site scripting vulnerability in Apache Wicket, published on 31 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Improper neutralization of input during web page generation in Apache Wicket.
org.apache.wicket.markup.html.form.Button clears the escape-model-strings flag in its constructor, so that the value attribute it writes is not encoded twice — ComponentTag already encodes attribute values when it writes the tag. That reasoning holds only for the attribute. When the component is attached to a <button> element rather than an <input>, it writes its model object into the element body instead, and nothing encodes an element body, so markup in the model is rendered as markup.
An application is affected where it renders a Button on a <button> element and that button's model holds data an attacker can influence. Wicket cannot determine where a model value comes from, so whether it reaches the page from a request or from storage is a property of the application. The subclasses that inherit this constructor — AjaxButton, AjaxFallbackButton and WizardButton — are affected on the same terms.
As a workaround, calling setEscapeModelStrings(true) on a button that renders as a <button> element escapes the body correctly, and does not cause double encoding, because the value attribute is written only for <input> elements.
This issue affects Apache Wicket: from 8.0.0 through 8.18.0, from 9.0.0 through 9.23.0, from 10.0.0 through 10.10.0. Older, unsupported releases from 6.25.0 and 7.5.0 onwards are also affected.
Users are recommended to upgrade to version 8.19.0, 9.24.0 or 10.11.0, which fix the issue.
Weakness: CWE-79
Which versions are affected by CVE-2026-76982?
It affects 1 product.
Products include Apache Wicket.
How do I fix CVE-2026-76982?
No fix has been published for CVE-2026-76982 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-76982 being exploited?
There is no known exploitation of CVE-2026-76982 in the wild and no public exploit code.
Other vulnerabilities in Apache Wicket
- CVE-2024-36522 Apache Wicket: Remote code execution via XSLT injection
- CVE-2026-40010 Apache Wicket: possible session fixation using AuthenticatedWebSession
- CVE-2016-6793 Deserialization in n/a
- CVE-2016-6806 Apache Wicket vulnerable to CSRF attacks
- CVE-2026-71257 Apache Wicket: Configured file upload limits are not enforced when the multipart request has already been parsed
Sources
Also known as GHSA-788m-qhxv-m7f3.