# CVE-2026-76982: Apache Wicket: XSS in Button via its model object

> Cross-site scripting vulnerability in Apache Wicket allows attackers to inject scripts via button model objects rendered in button elements.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/U:Amber`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 31 Aug 2026
- **Updated:** 31 Aug 2026
- **Also known as:** GHSA-788m-qhxv-m7f3

## What is CVE-2026-76982?

CVE-2026-76982 is a medium-severity cross-site scripting vulnerability in Apache Wicket, published on 31 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Improper neutralization of input during web page generation in Apache Wicket.

org.apache.wicket.markup.html.form.Button clears the escape-model-strings flag in its constructor, so that the value attribute it writes is not encoded twice — ComponentTag already encodes attribute values when it writes the tag. That reasoning holds only for the attribute. When the component is attached to a <button> element rather than an <input>, it writes its model object into the element body instead, and nothing encodes an element body, so markup in the model is rendered as markup.

An application is affected where it renders a Button on a <button> element and that button's model holds data an attacker can influence. Wicket cannot determine where a model value comes from, so whether it reaches the page from a request or from storage is a property of the application. The subclasses that inherit this constructor — AjaxButton, AjaxFallbackButton and WizardButton — are affected on the same terms.

As a workaround, calling setEscapeModelStrings(true) on a button that renders as a <button> element escapes the body correctly, and does not cause double encoding, because the value attribute is written only for <input> elements.

This issue affects Apache Wicket: from 8.0.0 through 8.18.0, from 9.0.0 through 9.23.0, from 10.0.0 through 10.10.0. Older, unsupported releases from 6.25.0 and 7.5.0 onwards are also affected.

Users are recommended to upgrade to version 8.19.0, 9.24.0 or 10.11.0, which fix the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-76982?

It affects 1 product.


Products: Apache Wicket.

## How do I fix CVE-2026-76982?

No fix has been published for CVE-2026-76982 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-76982 being exploited?

There is no known exploitation of CVE-2026-76982 in the wild and no public exploit code.

## Other vulnerabilities in Apache Wicket

- [CVE-2024-36522](https://insights.sbomify.com/CVE-2024-36522/): Apache Wicket: Remote code execution via XSLT injection (critical 9.8)
- [CVE-2026-40010](https://insights.sbomify.com/CVE-2026-40010/): Apache Wicket: possible session fixation using AuthenticatedWebSession (critical 9.1)
- [CVE-2016-6793](https://insights.sbomify.com/CVE-2016-6793/): Deserialization in n/a (critical 9.1)
- [CVE-2016-6806](https://insights.sbomify.com/CVE-2016-6806/): Apache Wicket vulnerable to CSRF attacks (high 8.8)
- [CVE-2026-71257](https://insights.sbomify.com/CVE-2026-71257/): Apache Wicket: Configured file upload limits are not enforced when the multipart request has already been parsed (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-76982 and fix it if it is affected.

What it is: CVE-2026-76982 is a medium-severity cross-site scripting vulnerability in Apache Wicket, published on 31 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-76982 in the wild and no public exploit code.

Affected product: Apache Wicket. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-76982/ (Markdown: https://insights.sbomify.com/CVE-2026-76982/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-76982
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-76982
- OSV: https://osv.dev/vulnerability/CVE-2026-76982

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-76982/
Summaries are generated and may contain mistakes; the official description above is the record.
