{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-76984 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-76984 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-76984 is a medium-severity cross-site scripting vulnerability in Apache Wicket, published on 31 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-76984 and fix it if it is affected.\n\nWhat it is: CVE-2026-76984 is a medium-severity cross-site scripting vulnerability in Apache Wicket, published on 31 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-76984 in the wild and no public exploit code.\n\nAffected product: Apache Wicket. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-76984/ (Markdown: https://insights.sbomify.com/CVE-2026-76984/index.md)","id":"CVE-2026-76984","markdown":"https://insights.sbomify.com/CVE-2026-76984/index.md","name":"CVE-2026-76984","record":{"aliases":["GHSA-f53h-v4wv-fq5x"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Java web framework","requires_auth":"low_privilege","summary":"An attacker can inject malicious scripts via improperly escaped attribute values in MetaDataHeaderItem, leading to cross-site scripting attacks.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"wicket","vendor":"apache"}],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/U:Amber","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Improper neutralization of input during web page generation in Apache Wicket.\n\norg.apache.wicket.markup.head.MetaDataHeaderItem generates \u003cmeta\u003e and \u003clink\u003e header tags. It escaped the attribute names it wrote, but ran the attribute values through a replacement of \" with \\\". A backslash before a double quote means nothing in HTML, so a value containing a double quote ends its own attribute and what follows is parsed as further attributes of the generated tag.\n\nAn application is affected where it supplies an attribute value holding data an attacker can influence, through addTagAttribute or the forMetaTag and forLinkTag factory methods. A value may be given as an IModel, so it is not necessarily a literal.\n\nThere is no setting to change; an application can only avoid supplying a value that contains a double quote. Note that these values have never been escaped effectively: before the change released in 6.24.0, 7.4.0 and 8.0.0 they were written with no escaping at all.\n\nThis issue affects Apache Wicket: from 8.0.0 through 8.18.0, from 9.0.0 through 9.23.0, from 10.0.0 through 10.10.0. Older, unsupported releases from 6.17.0 onwards are also affected. Users are recommended to upgrade to version 8.19.0, 9.24.0 or 10.11.0, which fix the issue.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Apache Wicket: XSS in MetaDataHeaderItem via addTagAttribute","id":"CVE-2026-76984","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"Apache Wicket: XSS in Palette via getAdditionalAttributes","id":"CVE-2026-76985"},"packages":[],"prev":{"headline":"Apache Wicket: XSS in AutoLabelTextResolver via FormComponent.setLabel","id":"CVE-2026-76983"},"products":["Apache Wicket"],"published":"2026-08-31","related":[{"cvss_score":9.8,"headline":"Apache Wicket: Remote code execution via XSLT injection","id":"CVE-2024-36522","kev_date_added":null,"published":"2024-07-12"},{"cvss_score":9.1,"headline":"Apache Wicket: possible session fixation using AuthenticatedWebSession","id":"CVE-2026-40010","kev_date_added":null,"published":"2026-05-06"},{"cvss_score":9.1,"headline":"Deserialization in n/a","id":"CVE-2016-6793","kev_date_added":null,"published":"2017-07-14"},{"cvss_score":8.8,"headline":"Apache Wicket vulnerable to CSRF attacks","id":"CVE-2016-6806","kev_date_added":null,"published":"2017-10-02"},{"cvss_score":7.5,"headline":"Apache Wicket: Configured file upload limits are not enforced when the multipart request has already been parsed","id":"CVE-2026-71257","kev_date_added":null,"published":"2026-08-31"},{"cvss_score":7.5,"headline":"Apache Wicket: crafted URLs can bypass PackageResourceGuard","id":"CVE-2026-43646","kev_date_added":null,"published":"2026-05-06"},{"cvss_score":7.5,"headline":"DNS proxy and possible amplification attack","id":"CVE-2021-23937","kev_date_added":null,"published":"2021-05-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-31","vendors":["Apache Software Foundation"]},"summary":"An attacker can inject malicious scripts via improperly escaped attribute values in MetaDataHeaderItem, leading to cross-site scripting attacks.","url":"https://insights.sbomify.com/CVE-2026-76984/"}