CVE-2026-76985 Apache Wicket: XSS in Palette via getAdditionalAttributes
Cross-site scripting vulnerability in Apache Wicket allows attackers to inject scripts if applications override specific attribute methods with unescaped user data.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2026-76985?
CVE-2026-76985 is a medium-severity cross-site scripting vulnerability in Apache Wicket, published on 31 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Improper neutralization of input during web page generation in Apache Wicket.
org.apache.wicket.extensions.markup.html.form.palette.component.AbstractOptions, which renders the two option lists of a Palette, escapes the id and the display value of each option according to the escape-model-strings setting, and wrote the attribute names and values returned by getAdditionalAttributes into the <option> tag as they came.
An application is affected where it overrides Palette.getAdditionalAttributesForChoices, Palette.getAdditionalAttributesForSelection or AbstractOptions.getAdditionalAttributes and returns a value holding data an attacker can influence. These methods return null by default, so an application that does not override them is not affected.
As a workaround, escape the values in the override.
This issue affects Apache Wicket: from 8.0.0 through 8.18.0, from 9.0.0 through 9.23.0, from 10.0.0 through 10.10.0. Older, unsupported releases from 1.4.0 onwards are also affected. Users are recommended to upgrade to version 8.19.0, 9.24.0 or 10.11.0, which fix the issue.
Weakness: CWE-79
Which versions are affected by CVE-2026-76985?
It affects 1 product.
Products include Apache Wicket.
How do I fix CVE-2026-76985?
No fix has been published for CVE-2026-76985 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-76985 being exploited?
There is no known exploitation of CVE-2026-76985 in the wild and no public exploit code.
Other vulnerabilities in Apache Wicket
- CVE-2024-36522 Apache Wicket: Remote code execution via XSLT injection
- CVE-2026-40010 Apache Wicket: possible session fixation using AuthenticatedWebSession
- CVE-2016-6793 Deserialization in n/a
- CVE-2016-6806 Apache Wicket vulnerable to CSRF attacks
- CVE-2026-71257 Apache Wicket: Configured file upload limits are not enforced when the multipart request has already been parsed
Sources
Also known as GHSA-85wm-m62p-pph5.