{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-76985 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-76985 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-76985 is a medium-severity cross-site scripting vulnerability in Apache Wicket, published on 31 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-76985 and fix it if it is affected.\n\nWhat it is: CVE-2026-76985 is a medium-severity cross-site scripting vulnerability in Apache Wicket, published on 31 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-76985 in the wild and no public exploit code.\n\nAffected product: Apache Wicket. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-76985/ (Markdown: https://insights.sbomify.com/CVE-2026-76985/index.md)","id":"CVE-2026-76985","markdown":"https://insights.sbomify.com/CVE-2026-76985/index.md","name":"CVE-2026-76985","record":{"aliases":["GHSA-85wm-m62p-pph5"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Java web framework","requires_auth":"low_privilege","summary":"Cross-site scripting vulnerability in Apache Wicket allows attackers to inject scripts if applications override specific attribute methods with unescaped user data.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"wicket","vendor":"apache"}],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/U:Green","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Improper neutralization of input during web page generation in Apache Wicket.\n\norg.apache.wicket.extensions.markup.html.form.palette.component.AbstractOptions, which renders the two option lists of a Palette, escapes the id and the display value of each option according to the escape-model-strings setting, and wrote the attribute names and values returned by getAdditionalAttributes into the \u003coption\u003e tag as they came.\n\nAn application is affected where it overrides Palette.getAdditionalAttributesForChoices, Palette.getAdditionalAttributesForSelection or AbstractOptions.getAdditionalAttributes and returns a value holding data an attacker can influence. These methods return null by default, so an application that does not override them is not affected.\n\nAs a workaround, escape the values in the override.\n\nThis issue affects Apache Wicket: from 8.0.0 through 8.18.0, from 9.0.0 through 9.23.0, from 10.0.0 through 10.10.0. Older, unsupported releases from 1.4.0 onwards are also affected. Users are recommended to upgrade to version 8.19.0, 9.24.0 or 10.11.0, which fix the issue.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Apache Wicket: XSS in Palette via getAdditionalAttributes","id":"CVE-2026-76985","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"Apache Wicket: XSS in AbstractSingleSelectChoice via getNullValidDisplayValue","id":"CVE-2026-76986"},"packages":[],"prev":{"headline":"Apache Wicket: XSS in MetaDataHeaderItem via addTagAttribute","id":"CVE-2026-76984"},"products":["Apache Wicket"],"published":"2026-08-31","related":[{"cvss_score":9.8,"headline":"Apache Wicket: Remote code execution via XSLT injection","id":"CVE-2024-36522","kev_date_added":null,"published":"2024-07-12"},{"cvss_score":9.1,"headline":"Apache Wicket: possible session fixation using AuthenticatedWebSession","id":"CVE-2026-40010","kev_date_added":null,"published":"2026-05-06"},{"cvss_score":9.1,"headline":"Deserialization in n/a","id":"CVE-2016-6793","kev_date_added":null,"published":"2017-07-14"},{"cvss_score":8.8,"headline":"Apache Wicket vulnerable to CSRF attacks","id":"CVE-2016-6806","kev_date_added":null,"published":"2017-10-02"},{"cvss_score":7.5,"headline":"Apache Wicket: Configured file upload limits are not enforced when the multipart request has already been parsed","id":"CVE-2026-71257","kev_date_added":null,"published":"2026-08-31"},{"cvss_score":7.5,"headline":"Apache Wicket: crafted URLs can bypass PackageResourceGuard","id":"CVE-2026-43646","kev_date_added":null,"published":"2026-05-06"},{"cvss_score":7.5,"headline":"DNS proxy and possible amplification attack","id":"CVE-2021-23937","kev_date_added":null,"published":"2021-05-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-31","vendors":["Apache Software Foundation"]},"summary":"Cross-site scripting vulnerability in Apache Wicket allows attackers to inject scripts if applications override specific attribute methods with unescaped user data.","url":"https://insights.sbomify.com/CVE-2026-76985/"}