# CVE-2026-76985: Apache Wicket: XSS in Palette via getAdditionalAttributes

> Cross-site scripting vulnerability in Apache Wicket allows attackers to inject scripts if applications override specific attribute methods with unescaped user data.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/U:Green`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 31 Aug 2026
- **Updated:** 31 Aug 2026
- **Also known as:** GHSA-85wm-m62p-pph5

## What is CVE-2026-76985?

CVE-2026-76985 is a medium-severity cross-site scripting vulnerability in Apache Wicket, published on 31 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Improper neutralization of input during web page generation in Apache Wicket.

org.apache.wicket.extensions.markup.html.form.palette.component.AbstractOptions, which renders the two option lists of a Palette, escapes the id and the display value of each option according to the escape-model-strings setting, and wrote the attribute names and values returned by getAdditionalAttributes into the <option> tag as they came.

An application is affected where it overrides Palette.getAdditionalAttributesForChoices, Palette.getAdditionalAttributesForSelection or AbstractOptions.getAdditionalAttributes and returns a value holding data an attacker can influence. These methods return null by default, so an application that does not override them is not affected.

As a workaround, escape the values in the override.

This issue affects Apache Wicket: from 8.0.0 through 8.18.0, from 9.0.0 through 9.23.0, from 10.0.0 through 10.10.0. Older, unsupported releases from 1.4.0 onwards are also affected. Users are recommended to upgrade to version 8.19.0, 9.24.0 or 10.11.0, which fix the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-76985?

It affects 1 product.


Products: Apache Wicket.

## How do I fix CVE-2026-76985?

No fix has been published for CVE-2026-76985 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-76985 being exploited?

There is no known exploitation of CVE-2026-76985 in the wild and no public exploit code.

## Other vulnerabilities in Apache Wicket

- [CVE-2024-36522](https://insights.sbomify.com/CVE-2024-36522/): Apache Wicket: Remote code execution via XSLT injection (critical 9.8)
- [CVE-2026-40010](https://insights.sbomify.com/CVE-2026-40010/): Apache Wicket: possible session fixation using AuthenticatedWebSession (critical 9.1)
- [CVE-2016-6793](https://insights.sbomify.com/CVE-2016-6793/): Deserialization in n/a (critical 9.1)
- [CVE-2016-6806](https://insights.sbomify.com/CVE-2016-6806/): Apache Wicket vulnerable to CSRF attacks (high 8.8)
- [CVE-2026-71257](https://insights.sbomify.com/CVE-2026-71257/): Apache Wicket: Configured file upload limits are not enforced when the multipart request has already been parsed (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-76985 and fix it if it is affected.

What it is: CVE-2026-76985 is a medium-severity cross-site scripting vulnerability in Apache Wicket, published on 31 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-76985 in the wild and no public exploit code.

Affected product: Apache Wicket. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-76985/ (Markdown: https://insights.sbomify.com/CVE-2026-76985/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-76985
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-76985
- OSV: https://osv.dev/vulnerability/CVE-2026-76985

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-76985/
Summaries are generated and may contain mistakes; the official description above is the record.
