CVE-2026-76986 Apache Wicket: XSS in AbstractSingleSelectChoice via getNullValidDisplayValue
Cross-site scripting in Apache Wicket allows attackers to inject scripts if developers override specific display value methods with unescaped user input.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2026-76986?
CVE-2026-76986 is a medium-severity cross-site scripting vulnerability in Apache Wicket, published on 31 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Improper neutralization of input during web page generation in Apache Wicket.
org.apache.wicket.markup.html.form.AbstractSingleSelectChoice, the base class of DropDownChoice, writes the body of the default option — the entry shown when no choice is selected — into the markup as it is, while every other option body in the same select is escaped according to the escape-model-strings setting. The body comes from getNullValidDisplayValue() or getNullKeyDisplayValue(), both of which are protected, so what they return is not necessarily the plain text the default implementation reads from a resource bundle.
An application is affected where it overrides one of those methods and returns a value holding data an attacker can influence, or where its own nullValid or null bundle entry holds such a value. The bundles shipped with Wicket contain plain text. RadioChoice overrides getDefaultChoice to emit no default option and is not affected.
As a workaround, escape the value in the override.
This issue affects Apache Wicket: from 8.0.0 through 8.18.0, from 9.0.0 through 9.23.0, from 10.0.0 through 10.10.0. Older, unsupported releases from 1.5.0 onwards are also affected. Users are recommended to upgrade to version 8.19.0, 9.24.0 or 10.11.0, which fix the issue.
Weakness: CWE-79
Which versions are affected by CVE-2026-76986?
It affects 1 product.
Products include Apache Wicket.
How do I fix CVE-2026-76986?
No fix has been published for CVE-2026-76986 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-76986 being exploited?
There is no known exploitation of CVE-2026-76986 in the wild and no public exploit code.
Other vulnerabilities in Apache Wicket
- CVE-2024-36522 Apache Wicket: Remote code execution via XSLT injection
- CVE-2026-40010 Apache Wicket: possible session fixation using AuthenticatedWebSession
- CVE-2016-6793 Deserialization in n/a
- CVE-2016-6806 Apache Wicket vulnerable to CSRF attacks
- CVE-2026-71257 Apache Wicket: Configured file upload limits are not enforced when the multipart request has already been parsed
Sources
Also known as GHSA-693x-mfgg-48mq.