{"answers":{"affected":"3 open source packages ship an affected version, including langflow.","exploited":"There is no known exploitation of CVE-2026-7700 in the wild and no public exploit code.","fix":"Upgrade langflow to 1.10.3 or later.","what":"CVE-2026-7700 is a medium-severity code injection vulnerability in langflow-ai langflow, published on 3 May 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-7700 and fix it if it is affected.\n\nWhat it is: CVE-2026-7700 is a medium-severity code injection vulnerability in langflow-ai langflow, published on 3 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-7700 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- langflow (PyPI): affected from 1.3.0; fixed in 1.10.3\n- langflow (PyPI): affected from 1.3.0; fixed in 1.10.3\n- langflow (PyPI): affected from 1.3.0; fixed in 1.10.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-7700/ (Markdown: https://insights.sbomify.com/CVE-2026-7700/index.md)","id":"CVE-2026-7700","markdown":"https://insights.sbomify.com/CVE-2026-7700/index.md","name":"CVE-2026-7700","record":{"aliases":["GHSA-9fpm-3445-2vx4","PYSEC-2026-4232"],"analysis":{"component_type":"web_application","fix_type":"no_fix_stated","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Langflow AI platform","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary code via the LambdaFilterComponent's eval function in Langflow, requiring immediate mitigation due to public exploit availability.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"A weakness has been identified in langflow-ai langflow up to 1.10.2. This affects the function eval of the file src/lfx/src/lfx/components/llm_operations/lambda_filter.py of the component LambdaFilterComponent. Executing a manipulation can lead to code injection. The attack may be performed from remote. The exploit has been made available to the public and could be used for attacks. The vendor was contacted early about this disclosure but did not respond in any way.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"langflow-ai langflow LambdaFilterComponent lambda_filter.py eval code injection","id":"CVE-2026-7700","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":3,"n_references":7,"next":{"headline":"Telegram Desktop Bot API url_auth_box.cpp RequestButton null pointer dereference","id":"CVE-2026-7701"},"packages":[{"ecosystem":"PyPI","fixed":["1.10.3"],"introduced":["1.3.0"],"last_affected":[],"package":"langflow","purl":null,"source":"GHSA-9fpm-3445-2vx4"},{"ecosystem":"PyPI","fixed":["1.10.3"],"introduced":["1.3.0"],"last_affected":[],"package":"langflow","purl":"pkg:pypi/langflow","source":"GHSA-9fpm-3445-2vx4"},{"ecosystem":"PyPI","fixed":["1.10.3"],"introduced":["1.3.0"],"last_affected":[],"package":"langflow","purl":"pkg:pypi/langflow","source":"PYSEC-2026-4232"}],"prev":{"headline":"Dromara MaxKey StrUtils.java StrUtils.checkSqlInjection sql injection","id":"CVE-2026-7699"},"products":["langflow"],"published":"2026-05-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-06","vendors":["langflow-ai"]},"summary":"Remote attackers can execute arbitrary code via the LambdaFilterComponent's eval function in Langflow, requiring immediate mitigation due to public exploit availability.","url":"https://insights.sbomify.com/CVE-2026-7700/"}