# CVE-2026-7700: langflow-ai langflow LambdaFilterComponent lambda_filter.py eval code injection

> Remote attackers can execute arbitrary code via the LambdaFilterComponent's eval function in Langflow, requiring immediate mitigation due to public exploit availability.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 May 2026
- **Updated:** 6 Oct 2026
- **Also known as:** GHSA-9fpm-3445-2vx4, PYSEC-2026-4232

## What is CVE-2026-7700?

CVE-2026-7700 is a medium-severity code injection vulnerability in langflow-ai langflow, published on 3 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A weakness has been identified in langflow-ai langflow up to 1.10.2. This affects the function eval of the file src/lfx/src/lfx/components/llm_operations/lambda_filter.py of the component LambdaFilterComponent. Executing a manipulation can lead to code injection. The attack may be performed from remote. The exploit has been made available to the public and could be used for attacks. The vendor was contacted early about this disclosure but did not respond in any way.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2026-7700?

3 open source packages ship an affected version, including langflow.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langflow` | PyPI | From 1.3.0 | 1.10.3 |
| `langflow` | PyPI | From 1.3.0 | 1.10.3 |
| `langflow` | PyPI | From 1.3.0 | 1.10.3 |

## How do I fix CVE-2026-7700?

Upgrade langflow to 1.10.3 or later.

## Is CVE-2026-7700 being exploited?

There is no known exploitation of CVE-2026-7700 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-7700 and fix it if it is affected.

What it is: CVE-2026-7700 is a medium-severity code injection vulnerability in langflow-ai langflow, published on 3 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-7700 in the wild and no public exploit code.

Affected packages and fixed versions:
- langflow (PyPI): affected from 1.3.0; fixed in 1.10.3
- langflow (PyPI): affected from 1.3.0; fixed in 1.10.3
- langflow (PyPI): affected from 1.3.0; fixed in 1.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-7700/ (Markdown: https://insights.sbomify.com/CVE-2026-7700/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-7700
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-7700
- OSV: https://osv.dev/vulnerability/CVE-2026-7700

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-7700/
Summaries are generated and may contain mistakes; the official description above is the record.
