# CVE-2026-77037: multer vulnerable to Denial of Service via file descriptor leak on aborted uploads

> Remote attackers can cause denial of service by leaking file descriptors through aborted uploads in the multer Node.js library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Aug 2026
- **Updated:** 31 Aug 2026
- **Also known as:** CLEANSTART-2026-FL31230, ECHO-65aa-dfa0-c380, GHSA-qfvm-cv95-jqjf, MINI-3jg4-mcf8-7wm3, MINI-63c9-mv84-4vcf, MINI-q3rr-c25j-h586, ROOT-APP-NPM-CVE-2026-77037

## What is CVE-2026-77037?

CVE-2026-77037 is a high-severity denial of service vulnerability in multer, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

multer is a middleware for handling multipart/form-data in Node.js. In version 2.2.0, when a disk-backed upload is aborted or truncated before the write stream finishes, multer's disk storage engine removes the visible file but does not close the underlying write file descriptor, leaving a deleted but still open descriptor. A remote attacker able to reach an upload route using the built-in disk storage can send repeated aborted or malformed multipart uploads, each one leaking a file descriptor and retaining disk blocks until the process exits, which can exhaust resources and cause a denial of service. The issue is fixed in multer 2.3.0, which closes the destination write stream on abnormal source termination and defers cleanup until the stream has closed. Upgrade to multer 2.3.0 to remediate.

Weakness: CWE-459 (Incomplete Cleanup), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-77037?

2 open source packages ship an affected version, including multer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `multer` | npm | From 2.2.0 | 2.3.0 |
| `multer` | npm | From 2.2.0 | 2.3.0 |

Products: Expressjs Multer.

## How do I fix CVE-2026-77037?

Upgrade multer to 2.3.0 or later.

## Is CVE-2026-77037 being exploited?

There is no known exploitation of CVE-2026-77037 in the wild and no public exploit code.

## Other vulnerabilities in multer

- [CVE-2026-3520](https://insights.sbomify.com/CVE-2026-3520/): Multer vulnerable to Denial of Service via uncontrolled recursion (high 8.7)
- [CVE-2026-2359](https://insights.sbomify.com/CVE-2026-2359/): Multer vulnerable to Denial of Service via resource exhaustion (high 8.7)
- [CVE-2026-3304](https://insights.sbomify.com/CVE-2026-3304/): Multer vulnerable to Denial of Service via incomplete cleanup (high 8.7)
- [CVE-2026-77078](https://insights.sbomify.com/CVE-2026-77078/): multer vulnerable to Denial of Service via crafted multipart field names (high 7.5)
- [CVE-2026-82333](https://insights.sbomify.com/CVE-2026-82333/): multer vulnerable to Denial of Service via oversized array index in field names (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77037 and fix it if it is affected.

What it is: CVE-2026-77037 is a high-severity denial of service vulnerability in multer, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-77037 in the wild and no public exploit code.

Affected packages and fixed versions:
- multer (npm): affected from 2.2.0; fixed in 2.3.0
- multer (npm): affected from 2.2.0; fixed in 2.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77037/ (Markdown: https://insights.sbomify.com/CVE-2026-77037/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77037
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77037
- OSV: https://osv.dev/vulnerability/CVE-2026-77037

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77037/
Summaries are generated and may contain mistakes; the official description above is the record.
