# CVE-2026-77053: Missing Authentication in Default Configuration in boneIO


- **Severity:** High 8.7 (`CVSS:4.0/AV:A/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 26 Oct 2026
- **Updated:** 26 Oct 2026
- **Also known as:** GHSA-82cx-36ph-pccq

## What is CVE-2026-77053?

CVE-2026-77053 is a high-severity vulnerability in boneIO, published on 26 Oct 2026. 

### Official description

boneIO Black firmware ships with authentication disabled by default. Its management web API listens on all network interfaces and exposes all endpoints without requiring credentials. An unauthenticated remote attacker can fully control the device, causing denial of service, modifying configuration, and operating connected physical circuits.
This issue was fixed in version 1.6.0: a device without an administrator account refuses API requests until the owner creates one in the first-run wizard, and every API route is restricted to an authenticated role.

Versions before 1.2.0 are based on Debian 10, are no longer supported and cannot be upgraded in place; affected devices should be re-flashed with the 1.6.0 system image.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-77053?


## How do I fix CVE-2026-77053?

No fix has been published for CVE-2026-77053 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-77053 being exploited?

There is no known exploitation of CVE-2026-77053 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77053 and fix it if it is affected.

What it is: CVE-2026-77053 is a high-severity vulnerability in boneIO, published on 26 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-77053 in the wild and no public exploit code.

Affected product: boneIO. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77053/ (Markdown: https://insights.sbomify.com/CVE-2026-77053/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77053
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77053
- OSV: https://osv.dev/vulnerability/CVE-2026-77053

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77053/
Summaries are generated and may contain mistakes; the official description above is the record.
