{"answers":{"affected":"2 open source packages ship an affected version, including multer. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-77078 in the wild and no public exploit code.","fix":"Upgrade multer to 2.3.0 or later.","what":"CVE-2026-77078 is a high-severity denial of service vulnerability in multer, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-77078 and fix it if it is affected.\n\nWhat it is: CVE-2026-77078 is a high-severity denial of service vulnerability in multer, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-77078 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- multer (npm): affected all versions; fixed in 2.3.0\n- multer (npm): affected all versions; fixed in 2.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-77078/ (Markdown: https://insights.sbomify.com/CVE-2026-77078/index.md)","id":"CVE-2026-77078","markdown":"https://insights.sbomify.com/CVE-2026-77078/index.md","name":"CVE-2026-77078","record":{"aliases":["CLEANSTART-2026-SY10703","ECHO-fc2c-5e78-0dc2","GHSA-wc9g-mqfw-jrwm","MINI-7mrp-j9g3-2cfm","MINI-9w7f-8f94-rjr5","MINI-pfgx-j48p-fmwh","ROOT-APP-NPM-CVE-2026-77078"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js multipart middleware","requires_auth":"none","summary":"Attackers can crash Node.js applications by sending crafted multipart requests with specific field names, requiring an upgrade to the multer library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"openjs","cpe":[{"product":"multer","vendor":"expressjs"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-248","name":"Uncaught Exception"}],"description":"multer is a middleware for handling multipart/form-data in Node.js. A small multipart request containing two specially crafted text field names can cause an uncaught RangeError (Invalid array length) that terminates the Node.js process. The first field uses a very large numeric array index to allocate a maximum-length sparse array, and a second field then pushes past that length, which throws inside the append-field dependency and is not caught by multer. All versions before 2.3.0 are affected, and the issue is a remotely triggerable denial of service. The issue is fixed in multer 2.3.0. Upgrade to multer 2.3.0 to remediate.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":"2026-09-21","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-09-21T12:12:57Z","kind":"github_poc","ref":"https://github.com/wtfkimi/CVE-2026-77078","stars":0,"title":"Example how to use this CVE"}],"tier":"poc_unverified"},"has_fix":true,"headline":"multer vulnerable to Denial of Service via crafted multipart field names","id":"CVE-2026-77078","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"n8n before 2.34.1 Authorization Bypass via Custom Role Deletion","id":"CVE-2026-77079"},"packages":[{"ecosystem":"npm","fixed":["2.3.0"],"introduced":["0"],"last_affected":[],"package":"multer","purl":null,"source":"GHSA-wc9g-mqfw-jrwm"},{"ecosystem":"npm","fixed":["2.3.0"],"introduced":["0"],"last_affected":[],"package":"multer","purl":"pkg:npm/multer","source":"GHSA-wc9g-mqfw-jrwm"}],"prev":{"headline":"n8n before 1.123.69 Remote Code Execution via EventEmitter Prototype Pollution","id":"CVE-2026-77077"},"products":["multer"],"published":"2026-08-28","related":[{"cvss_score":8.7,"headline":"Multer vulnerable to Denial of Service via uncontrolled recursion","id":"CVE-2026-3520","kev_date_added":null,"published":"2026-03-04"},{"cvss_score":8.7,"headline":"Multer vulnerable to Denial of Service via resource exhaustion","id":"CVE-2026-2359","kev_date_added":null,"published":"2026-02-27"},{"cvss_score":8.7,"headline":"Multer vulnerable to Denial of Service via incomplete cleanup","id":"CVE-2026-3304","kev_date_added":null,"published":"2026-02-27"},{"cvss_score":7.5,"headline":"multer vulnerable to Denial of Service via file descriptor leak on aborted uploads","id":"CVE-2026-77037","kev_date_added":null,"published":"2026-08-28"},{"cvss_score":7.5,"headline":"multer vulnerable to Denial of Service via oversized array index in field names","id":"CVE-2026-82333","kev_date_added":null,"published":"2026-08-28"},{"cvss_score":7.5,"headline":"multer vulnerable to Denial of Service via deeply nested field names","id":"CVE-2026-5079","kev_date_added":null,"published":"2026-06-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-31","vendors":["multer"]},"summary":"Attackers can crash Node.js applications by sending crafted multipart requests with specific field names, requiring an upgrade to the multer library.","url":"https://insights.sbomify.com/CVE-2026-77078/"}