# CVE-2026-77088: justhtml 0.9.0 through 1.21.0 Cross-Site Scripting via code-span

> Attackers can inject blank lines into code spans to bypass sanitization, causing unescaped HTML to be rendered as live Markdown, leading to XSS.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 23 Aug 2026
- **Updated:** 29 Aug 2026
- **Also known as:** GHSA-3r4x-v5v7-fm2r, GHSA-jf6w-2mvx-633j

## What is CVE-2026-77088?

CVE-2026-77088 is a medium-severity cross-site scripting vulnerability in EmilStenstrom justhtml, published on 23 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

justhtml versions 0.9.0 through 1.21.0 contain a cross-site scripting vulnerability in to_markdown() where inline code spans fail to account for blank lines as block boundaries. Attackers can inject blank lines into code or pre element text to break the inline span, causing sanitized HTML to be emitted unescaped and re-parsed as live Markdown by compliant renderers.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-77088?

2 open source packages ship an affected version, including justhtml.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `justhtml` | PyPI | From 0.9.0 | 1.22.0 |
| `justhtml` | PyPI | From 0.9.0 | 1.22.0 |

## How do I fix CVE-2026-77088?

Upgrade justhtml to 1.22.0 or later.

## Is CVE-2026-77088 being exploited?

There is no known exploitation of CVE-2026-77088 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77088 and fix it if it is affected.

What it is: CVE-2026-77088 is a medium-severity cross-site scripting vulnerability in EmilStenstrom justhtml, published on 23 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-77088 in the wild and no public exploit code.

Affected packages and fixed versions:
- justhtml (PyPI): affected from 0.9.0; fixed in 1.22.0
- justhtml (PyPI): affected from 0.9.0; fixed in 1.22.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77088/ (Markdown: https://insights.sbomify.com/CVE-2026-77088/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77088
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77088
- OSV: https://osv.dev/vulnerability/CVE-2026-77088

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77088/
Summaries are generated and may contain mistakes; the official description above is the record.
