CVE-2026-77147 Apache Syncope: Groovy Sandbox escape for empty CommandArgs
Administrators can bypass Groovy sandbox restrictions to execute arbitrary code via malicious CommandArgs in Apache Syncope.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-77147?
CVE-2026-77147 is a medium-severity code injection vulnerability in Apache Syncope, published on 14 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Syncope.
An administrator with adequate entitlements for Implementations can create a malicious Groovy Command class containing untrusted code in their CommandArgs static implementation, bypassing the Groovy security sandbox.
This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.7, from 4.1.0-M0 through 4.1.2.
Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fix this issue.
Weakness: CWE-94
Which versions are affected by CVE-2026-77147?
How do I fix CVE-2026-77147?
No fix has been published for CVE-2026-77147 yet. Limit exposure of the affected software until one is available.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-77147 being exploited?
There is no known exploitation of CVE-2026-77147 in the wild and no public exploit code.
Sources
Also known as GHSA-fp6q-c836-37rh.