# CVE-2026-77164: Server-side request forgery in Server

> Unauthenticated attackers can force Nextcloud servers to make internal requests via Circles app, bypassing SSRF protections to probe internal services.

- **Severity:** Medium 6.2 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Sep 2026
- **Updated:** 18 Sep 2026
- **Also known as:** BIT-nextcloud-2026-77164, GHSA-h4g5-x94v-qxqg

## What is CVE-2026-77164?

CVE-2026-77164 is a medium-severity server-side request forgery vulnerability in Nextcloud Server, published on 18 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Circles' remote-instance signature verification fetches the attacker-supplied keyId URL before trust in the remote instance is established, and explicitly allows local/private addresses for this request, bypassing Nextcloud's core SSRF protections. The public, unauthenticated endpoints POST /apps/circles/event/ and POST /apps/circles/incoming/ reach this code path, allowing any unauthenticated user to force the server to issue a GET request to an internal address.

The response body of the internal request is never returned to the requester, so this is blind SSRF: an attacker can determine whether an internal service is reachable, but cannot read its response contents through this endpoint alone.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-77164?

1 open source package ship an affected version, including nextcloud.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nextcloud` | Bitnami | From 31.0.0 | 34.0.1 |

## How do I fix CVE-2026-77164?

Upgrade nextcloud to 34.0.1 or later.

## Is CVE-2026-77164 being exploited?

There is no known exploitation of CVE-2026-77164 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77164 and fix it if it is affected.

What it is: CVE-2026-77164 is a medium-severity server-side request forgery vulnerability in Nextcloud Server, published on 18 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-77164 in the wild and no public exploit code.

Affected packages and fixed versions:
- nextcloud (Bitnami): affected from 31.0.0; fixed in 34.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77164/ (Markdown: https://insights.sbomify.com/CVE-2026-77164/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77164
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77164
- OSV: https://osv.dev/vulnerability/CVE-2026-77164

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77164/
Summaries are generated and may contain mistakes; the official description above is the record.
