# CVE-2026-77165: Business logic in Server

> File owners cannot unlock files locked by other users, causing permanent file locks and denial of service in Nextcloud Server.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Sep 2026
- **Updated:** 21 Sep 2026
- **Also known as:** BIT-nextcloud-2026-77165, GHSA-77h3-rj6p-8wj8, MINI-gg48-wpf6-3mpp

## What is CVE-2026-77165?

CVE-2026-77165 is a medium-severity vulnerability in Nextcloud Server, published on 21 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

File owners were unable to unlock TYPE_TOKEN locks placed by other users, leaving files permanently locked with no recovery path outside of the database.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-77165?

1 open source package ship an affected version, including nextcloud.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nextcloud` | Bitnami | From 32.0.0 | 34.0.1 |

## How do I fix CVE-2026-77165?

Upgrade nextcloud to 34.0.1 or later.

## Is CVE-2026-77165 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-77165 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77165 and fix it if it is affected.

What it is: CVE-2026-77165 is a medium-severity vulnerability in Nextcloud Server, published on 21 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-77165 exists.

Affected packages and fixed versions:
- nextcloud (Bitnami): affected from 32.0.0; fixed in 34.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77165/ (Markdown: https://insights.sbomify.com/CVE-2026-77165/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77165
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77165
- OSV: https://osv.dev/vulnerability/CVE-2026-77165

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77165/
Summaries are generated and may contain mistakes; the official description above is the record.
