CVE-2026-77181 Apache Syncope: ClientApp update entitlement not effective
Apache Syncope incorrectly checks create entitlements for update operations, preventing authorized administrators from updating ClientApps.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-77181?
CVE-2026-77181 is a critical missing authorization vulnerability in Apache Syncope, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Incorrect Authorization vulnerability in Apache Syncope.
An administrator with ClientApp's update entitlement is unable to perform the related operation, while ClientApp's create entitlement is checked both for create and update operations on ClientApp.
This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.7, from 4.1.0-M0 through 4.1.2.
Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fix this issue.
Weakness: CWE-863
Which versions are affected by CVE-2026-77181?
How do I fix CVE-2026-77181?
No fix has been published for CVE-2026-77181 yet. Limit exposure of the affected software until one is available.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-77181 being exploited?
There is no known exploitation of CVE-2026-77181 in the wild and no public exploit code.
Sources
Also known as GHSA-xggf-jv35-5g43.