# CVE-2026-77194: Auth bypass in Simple Membership

> Unauthenticated attackers can take over Administrator accounts in WordPress Multisite by exploiting improper identity verification during registration.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 1 Sep 2026
- **Updated:** 1 Sep 2026
- **Also known as:** GHSA-w48h-3prc-xgxg

## What is CVE-2026-77194?

CVE-2026-77194 is a medium-severity authentication bypass vulnerability in wpinsider-1 Simple Membership, published on 1 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Simple Membership plugin for WordPress is vulnerable to Authentication Bypass leading to Administrator Account Takeover in versions up to, and including, 4.8.0. This is due to improper identity verification during the public registration flow in WordPress Multisite environments, where the plugin binds new Simple Membership records to existing global WordPress users based solely on matching username and email, without requiring password verification or ownership proof, and fails to properly detect Administrator roles on child sites. This makes it possible for unauthenticated attackers to take over Administrator accounts on child sites in a Multisite network by registering a Simple Membership account with a victim's credentials on a site where public registration is enabled, then updating the victim's global WordPress password through the profile edit functionality. The vulnerability was partially patched in version 4.8.1.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-77194?


## How do I fix CVE-2026-77194?

No fix has been published for CVE-2026-77194 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-77194 being exploited?

There is no known exploitation of CVE-2026-77194 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77194 and fix it if it is affected.

What it is: CVE-2026-77194 is a medium-severity authentication bypass vulnerability in wpinsider-1 Simple Membership, published on 1 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-77194 in the wild and no public exploit code.

Affected product: wpinsider-1 Simple Membership. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77194/ (Markdown: https://insights.sbomify.com/CVE-2026-77194/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77194
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77194
- OSV: https://osv.dev/vulnerability/CVE-2026-77194

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77194/
Summaries are generated and may contain mistakes; the official description above is the record.
