# CVE-2026-7722: PrefectHQ prefect Health Check API health endswith improper authentication

> Attackers can bypass authentication on the Prefect Health Check API endpoint, potentially exposing health status information.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 May 2026
- **Updated:** 4 May 2026
- **Also known as:** GHSA-6rr6-v7cj-mxpg, PYSEC-2026-2956, ROOT-APP-PYPI-CVE-2026-7722

## What is CVE-2026-7722?

CVE-2026-7722 is a medium-severity authentication bypass vulnerability in PrefectHQ prefect, published on 4 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability was detected in PrefectHQ prefect up to 3.6.21. This impacts the function endswith of the file /api/health of the component Health Check API. Performing a manipulation results in improper authentication. The attack is possible to be carried out remotely. The exploit is now public and may be used. Upgrading to version 3.6.22 will fix this issue. The patch is named e21617125335025b4b27e7d6f0ca028e8e8f3b79. Upgrading the affected component is recommended. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-7722?

3 open source packages ship an affected version, including prefect.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `prefect` | PyPI | All versions | 3.6.22 |
| `prefect` | PyPI | All versions | 3.6.22 |
| `prefect` | PyPI | All versions | 3.6.22 |

## How do I fix CVE-2026-7722?

Upgrade prefect to 3.6.22 or later.

## Is CVE-2026-7722 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7722 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-7722 and fix it if it is affected.

What it is: CVE-2026-7722 is a medium-severity authentication bypass vulnerability in PrefectHQ prefect, published on 4 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7722 exists.

Affected packages and fixed versions:
- prefect (PyPI): affected all versions; fixed in 3.6.22
- prefect (PyPI): affected all versions; fixed in 3.6.22
- prefect (PyPI): affected all versions; fixed in 3.6.22

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-7722/ (Markdown: https://insights.sbomify.com/CVE-2026-7722/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-7722
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-7722
- OSV: https://osv.dev/vulnerability/CVE-2026-7722

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-7722/
Summaries are generated and may contain mistakes; the official description above is the record.
