# CVE-2026-7723: PrefectHQ prefect WebSocket Endpoint in missing authentication

> Remote attackers can access the WebSocket endpoint without authentication, bypassing security controls in the Prefect workflow library.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 May 2026
- **Updated:** 4 May 2026
- **Also known as:** GHSA-hvph-5985-r63v, PYSEC-2026-2958, ROOT-APP-PYPI-CVE-2026-7723

## What is CVE-2026-7723?

CVE-2026-7723 is a medium-severity missing authorization vulnerability in PrefectHQ prefect, published on 4 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw has been found in PrefectHQ prefect up to 3.6.13. Affected is an unknown function of the file /api/events/in of the component WebSocket Endpoint. Executing a manipulation can lead to missing authentication. The attack may be performed from remote. The exploit has been published and may be used. Upgrading to version 3.6.14 is able to address this issue. This patch is called f8afecadf88ea5f73694dafa3a365b9d8fae1ad6. It is recommended to upgrade the affected component. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.

Weakness: CWE-306 (Missing Authentication for Critical Functionality), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-7723?

3 open source packages ship an affected version, including prefect.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `prefect` | PyPI | All versions | 3.6.14 |
| `prefect` | PyPI | All versions | 3.6.14 |
| `prefect` | PyPI | All versions | 3.6.14 |

## How do I fix CVE-2026-7723?

Upgrade prefect to 3.6.14 or later.

## Is CVE-2026-7723 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7723 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-7723 and fix it if it is affected.

What it is: CVE-2026-7723 is a medium-severity missing authorization vulnerability in PrefectHQ prefect, published on 4 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7723 exists.

Affected packages and fixed versions:
- prefect (PyPI): affected all versions; fixed in 3.6.14
- prefect (PyPI): affected all versions; fixed in 3.6.14
- prefect (PyPI): affected all versions; fixed in 3.6.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-7723/ (Markdown: https://insights.sbomify.com/CVE-2026-7723/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-7723
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-7723
- OSV: https://osv.dev/vulnerability/CVE-2026-7723

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-7723/
Summaries are generated and may contain mistakes; the official description above is the record.
