{"answers":{"affected":"3 open source packages ship an affected version, including prefect.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7725 exists.","fix":"Upgrade prefect to 3.6.25.dev7 or later.","what":"CVE-2026-7725 is a medium-severity command injection vulnerability in PrefectHQ prefect, published on 4 May 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-7725 and fix it if it is affected.\n\nWhat it is: CVE-2026-7725 is a medium-severity command injection vulnerability in PrefectHQ prefect, published on 4 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7725 exists.\n\nAffected packages and fixed versions:\n- prefect (PyPI): affected all versions; fixed in 3.6.25.dev7\n- prefect (PyPI): affected all versions; fixed in 3.6.25.dev7\n- prefect (PyPI): affected all versions; fixed in 3.6.25.dev7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-7725/ (Markdown: https://insights.sbomify.com/CVE-2026-7725/index.md)","id":"CVE-2026-7725","markdown":"https://insights.sbomify.com/CVE-2026-7725/index.md","name":"CVE-2026-7725","record":{"aliases":["GHSA-6rcx-55r6-jx65","PYSEC-2026-2955"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python workflow library","requires_auth":"low_privilege","summary":"Attackers can inject arguments into GitRepository Pull operations in Prefect, potentially leading to remote code execution.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-88","name":"Improper Neutralization of Argument Delimiters in a Command"},{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"A vulnerability was found in PrefectHQ prefect up to 3.6.25.dev6. Affected by this issue is some unknown functionality of the file src/prefect/runner/storage.py of the component GitRepository Pull Handler. The manipulation of the argument commit_sha/directories results in argument injection. It is possible to launch the attack remotely. The exploit has been made public and could be used. Upgrading to version 3.6.25.dev7 can resolve this issue. The patch is identified as 6a9d9918716ce4ee0297b69f3046f7067ef1faae. It is advisable to upgrade the affected component. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"PrefectHQ prefect GitRepository Pull storage.py argument injection","id":"CVE-2026-7725","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":3,"n_references":8,"next":{"headline":"Missing authorization in Layouts for WPBakery","id":"CVE-2026-7726"},"packages":[{"ecosystem":"PyPI","fixed":["3.6.25.dev7"],"introduced":["0"],"last_affected":[],"package":"prefect","purl":null,"source":"GHSA-6rcx-55r6-jx65"},{"ecosystem":"PyPI","fixed":["3.6.25.dev7"],"introduced":["0"],"last_affected":[],"package":"prefect","purl":"pkg:pypi/prefect","source":"GHSA-6rcx-55r6-jx65"},{"ecosystem":"PyPI","fixed":["3.6.25.dev7"],"introduced":["0"],"last_affected":[],"package":"prefect","purl":"pkg:pypi/prefect","source":"PYSEC-2026-2955"}],"prev":{"headline":"PrefectHQ prefect Webhook/Notification validate_restricted_url toctou","id":"CVE-2026-7724"},"products":["prefect"],"published":"2026-05-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-05","vendors":["PrefectHQ"]},"summary":"Attackers can inject arguments into GitRepository Pull operations in Prefect, potentially leading to remote code execution.","url":"https://insights.sbomify.com/CVE-2026-7725/"}