# CVE-2026-77258: MCP Atlassian: Arbitrary file read/exfiltration via upload_attachment missing validate_safe_path()

> An attacker can read arbitrary server files by manipulating the file path in the upload_attachment function, leading to data disclosure.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Sep 2026
- **Updated:** 25 Sep 2026
- **Also known as:** GHSA-93xw-j965-9mx3, PYSEC-2026-4088

## What is CVE-2026-77258?

CVE-2026-77258 is a high-severity path traversal vulnerability in sooperset mcp-atlassian, published on 22 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

MCP Atlassian is a Model Context Protocol (MCP) server for Atlassian products (Confluence and Jira). Prior to 0.22.0, upload_attachment in src/mcp_atlassian/confluence/attachments.py accepts a caller-controlled file_path and opens the selected server-local file without restricting it to the workspace. A permitted Confluence MCP caller can upload the file as an attachment and disclose data readable by the server process. This issue is fixed in version 0.22.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-77258?

3 open source packages ship an affected version, including mcp-atlassian. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mcp-atlassian` | PyPI | All versions | 0.22.0 |
| `mcp-atlassian` | PyPI | All versions | 0.22.0 |
| `mcp-atlassian` | PyPI | All versions | 0.22.0 |

Products: Mcp-Atlassian Mcp Atlassian.

## How do I fix CVE-2026-77258?

Upgrade mcp-atlassian to 0.22.0 or later.

## Is CVE-2026-77258 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-77258 exists.

## Other vulnerabilities in sooperset mcp-atlassian

- [CVE-2026-77244](https://insights.sbomify.com/CVE-2026-77244/): [mcp-atlassian] Authentication bypass in HTTP transport: AtlassianOpaqueTokenVerifier accepts any non-empty token (critical 10.0)
- [CVE-2026-77254](https://insights.sbomify.com/CVE-2026-77254/): MCP Atlassian: Unauthenticated HTTP MCP requests can use globally configured Jira and Confluence credentials (critical 9.1)
- [CVE-2026-27825](https://insights.sbomify.com/CVE-2026-27825/): MCP Atlassian has an arbitrary file write leading to arbitrary code execution via unconstrained download_path in confluence_download_attachment (critical 9.1)
- [CVE-2026-77243](https://insights.sbomify.com/CVE-2026-77243/): MCP Atlassian: ENABLED_TOOLS / Toolset authorization bypass (high 8.8)
- [CVE-2026-77274](https://insights.sbomify.com/CVE-2026-77274/): MCP Atlassian: SSRF Protection Bypass (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77258 and fix it if it is affected.

What it is: CVE-2026-77258 is a high-severity path traversal vulnerability in sooperset mcp-atlassian, published on 22 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-77258 exists.

Affected packages and fixed versions:
- mcp-atlassian (PyPI): affected all versions; fixed in 0.22.0
- mcp-atlassian (PyPI): affected all versions; fixed in 0.22.0
- mcp-atlassian (PyPI): affected all versions; fixed in 0.22.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77258/ (Markdown: https://insights.sbomify.com/CVE-2026-77258/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77258
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77258
- OSV: https://osv.dev/vulnerability/CVE-2026-77258

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77258/
Summaries are generated and may contain mistakes; the official description above is the record.
