# CVE-2026-77262: MCP Atlassian: Path Traversal / Arbitrary File Read in confluence_upload_attachment MCP tool (incomplete fix of GHSA-xjgw-4wvw-rgm4)

> Attackers can traverse directories to read arbitrary server files and upload them to Confluence via the MCP Atlassian server.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Sep 2026
- **Updated:** 28 Sep 2026
- **Also known as:** GHSA-p6hp-93wp-fh6p, PYSEC-2026-4099

## What is CVE-2026-77262?

CVE-2026-77262 is a high-severity path traversal vulnerability in sooperset mcp-atlassian, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

MCP Atlassian is a Model Context Protocol (MCP) server for Atlassian products (Confluence and Jira). Prior to 0.22.0, confluence_upload_attachment accepts an attacker-controlled file_path and does not apply the path restriction added for the earlier download vulnerability. A caller can traverse outside the workspace and upload arbitrary server-readable files to Confluence. The advisory traces the vulnerable input and processing flow through confluence_upload_attachment, file_path, and CVE-2026-27825, which identify the affected entry points, controls, and code paths. This issue is fixed in version 0.22.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-77262?

3 open source packages ship an affected version, including mcp-atlassian. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mcp-atlassian` | PyPI | All versions | 0.22.0 |
| `mcp-atlassian` | PyPI | All versions | 0.22.0 |
| `mcp-atlassian` | PyPI | All versions | 0.22.0 |

Products: Mcp-Atlassian Mcp Atlassian.

## How do I fix CVE-2026-77262?

Upgrade mcp-atlassian to 0.22.0 or later.

## Is CVE-2026-77262 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-77262 exists.

Public exploit code:

- Arbitrary file read in mcp-atlassian via confluence_upload_attachment — CVE-2026-77262 / GHSA-p6hp-93wp-fh6p (github_poc): https://github.com/romain-deperne/CVE-2026-77262

## Other vulnerabilities in sooperset mcp-atlassian

- [CVE-2026-77244](https://insights.sbomify.com/CVE-2026-77244/): [mcp-atlassian] Authentication bypass in HTTP transport: AtlassianOpaqueTokenVerifier accepts any non-empty token (critical 10.0)
- [CVE-2026-77254](https://insights.sbomify.com/CVE-2026-77254/): MCP Atlassian: Unauthenticated HTTP MCP requests can use globally configured Jira and Confluence credentials (critical 9.1)
- [CVE-2026-27825](https://insights.sbomify.com/CVE-2026-27825/): MCP Atlassian has an arbitrary file write leading to arbitrary code execution via unconstrained download_path in confluence_download_attachment (critical 9.1)
- [CVE-2026-77243](https://insights.sbomify.com/CVE-2026-77243/): MCP Atlassian: ENABLED_TOOLS / Toolset authorization bypass (high 8.8)
- [CVE-2026-77274](https://insights.sbomify.com/CVE-2026-77274/): MCP Atlassian: SSRF Protection Bypass (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77262 and fix it if it is affected.

What it is: CVE-2026-77262 is a high-severity path traversal vulnerability in sooperset mcp-atlassian, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-77262 exists.

Affected packages and fixed versions:
- mcp-atlassian (PyPI): affected all versions; fixed in 0.22.0
- mcp-atlassian (PyPI): affected all versions; fixed in 0.22.0
- mcp-atlassian (PyPI): affected all versions; fixed in 0.22.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77262/ (Markdown: https://insights.sbomify.com/CVE-2026-77262/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77262
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77262
- OSV: https://osv.dev/vulnerability/CVE-2026-77262

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77262/
Summaries are generated and may contain mistakes; the official description above is the record.
