{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-77281 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-77281 is a medium-severity vulnerability in caddyserver caddy, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-77281 and fix it if it is affected.\n\nWhat it is: CVE-2026-77281 is a medium-severity vulnerability in caddyserver caddy, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-77281 in the wild and no public exploit code.\n\nAffected product: caddyserver caddy. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-77281/ (Markdown: https://insights.sbomify.com/CVE-2026-77281/index.md)","id":"CVE-2026-77281","markdown":"https://insights.sbomify.com/CVE-2026-77281/index.md","name":"CVE-2026-77281","record":{"aliases":["DEBIAN-CVE-2026-77281","MINI-55pp-x7m2-gv6w","MINI-wwv5-9536-69j8","UBUNTU-CVE-2026-77281"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Caddy web server","requires_auth":"none","summary":"Attackers can exploit rewrite placeholder re-expansion to disclose sensitive data and readable files if specific rewrite configurations are used.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"},{"id":"CWE-178","name":"Improper Handling of Case Sensitivity"}],"description":"Caddy is an extensible server platform that uses TLS by default. In version 2.11.3 and earlier, three configuration-dependent weaknesses affect the handler and placeholder layer. In modules/caddyhttp/rewrite/rewrite.go, Rewrite.Rewrite() can pass attacker-controlled replacement bytes through buildQueryString for a second placeholder expansion when a rewrite URI ends with a literal question mark, allowing injected environment or request-variable placeholders to disclose data and, when the file provider is registered, allowing injected file placeholders to disclose readable files. The  issue is fixed in version 2.11.4.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Caddy: rewrite placeholder re-expansion","id":"CVE-2026-77281","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":0,"n_references":4,"next":{"headline":"OpenBao Agent Writes Secrets to Stdout","id":"CVE-2026-77285"},"packages":[],"prev":{"headline":"MCP Atlassian: SSRF Protection Bypass","id":"CVE-2026-77274"},"products":["caddy"],"published":"2026-09-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-18","vendors":["caddyserver"]},"summary":"Attackers can exploit rewrite placeholder re-expansion to disclose sensitive data and readable files if specific rewrite configurations are used.","url":"https://insights.sbomify.com/CVE-2026-77281/"}