# CVE-2026-77281: Caddy: rewrite placeholder re-expansion

> Attackers can exploit rewrite placeholder re-expansion to disclose sensitive data and readable files if specific rewrite configurations are used.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2026
- **Updated:** 18 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-77281, MINI-55pp-x7m2-gv6w, MINI-wwv5-9536-69j8, UBUNTU-CVE-2026-77281

## What is CVE-2026-77281?

CVE-2026-77281 is a medium-severity vulnerability in caddyserver caddy, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Caddy is an extensible server platform that uses TLS by default. In version 2.11.3 and earlier, three configuration-dependent weaknesses affect the handler and placeholder layer. In modules/caddyhttp/rewrite/rewrite.go, Rewrite.Rewrite() can pass attacker-controlled replacement bytes through buildQueryString for a second placeholder expansion when a rewrite URI ends with a literal question mark, allowing injected environment or request-variable placeholders to disclose data and, when the file provider is registered, allowing injected file placeholders to disclose readable files. The  issue is fixed in version 2.11.4.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-178 (Improper Handling of Case Sensitivity)

## Which versions are affected by CVE-2026-77281?


## How do I fix CVE-2026-77281?

Upgrade to a fixed version.

## Is CVE-2026-77281 being exploited?

There is no known exploitation of CVE-2026-77281 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77281 and fix it if it is affected.

What it is: CVE-2026-77281 is a medium-severity vulnerability in caddyserver caddy, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-77281 in the wild and no public exploit code.

Affected product: caddyserver caddy. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77281/ (Markdown: https://insights.sbomify.com/CVE-2026-77281/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77281
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77281
- OSV: https://osv.dev/vulnerability/CVE-2026-77281

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77281/
Summaries are generated and may contain mistakes; the official description above is the record.
