# CVE-2026-77317: SeaweedFS: SFTP path ACL literal prefix match permits cross-tenant file read and overwrite

> Authenticated SFTP users can bypass path ACLs to read or overwrite other tenants' files due to improper prefix matching.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Aug 2026
- **Updated:** 29 Aug 2026
- **Also known as:** BIT-seaweedfs-2026-77317, GHSA-fvpg-g364-j8vh, MINI-96gh-x663-8cmw

## What is CVE-2026-77317?

CVE-2026-77317 is a high-severity missing authorization vulnerability in seaweedfs, published on 26 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

SeaweedFS is a distributed storage system for files and blobs. In versions from 3.88 through 4.39, the SFTP server evaluates configured path permissions with a literal string-prefix comparison, so a user scoped to a path is also granted the same access to any sibling path whose name merely begins with the same characters. A user granted access to /tenants/alice therefore also matches /tenants/alice-archive, /tenants/alice2, and similar siblings, because the check does not require a path-component boundary. An authenticated low-privilege SFTP user with a root home directory and narrow path permissions can thereby cross the configured ACL boundary to read another tenant's files, and to overwrite them if granted write, all through the documented SFTP service with its own valid credentials. This issue is fixed in version 4.40.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-77317?

1 open source package ship an affected version, including seaweedfs.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `seaweedfs` | Bitnami | From 3.88.0 | 4.40.0 |

## How do I fix CVE-2026-77317?

Upgrade seaweedfs to 4.40.0 or later.

## Is CVE-2026-77317 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-77317 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77317 and fix it if it is affected.

What it is: CVE-2026-77317 is a high-severity missing authorization vulnerability in seaweedfs, published on 26 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-77317 exists.

Affected packages and fixed versions:
- seaweedfs (Bitnami): affected from 3.88.0; fixed in 4.40.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77317/ (Markdown: https://insights.sbomify.com/CVE-2026-77317/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77317
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77317
- OSV: https://osv.dev/vulnerability/CVE-2026-77317

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77317/
Summaries are generated and may contain mistakes; the official description above is the record.
