# CVE-2026-77322: SIPGO: DoS via unvalidated WebSocket frame length

> An unauthenticated attacker can crash the server or exhaust memory by sending a WebSocket frame with an excessively large declared length.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Sep 2026
- **Updated:** 23 Sep 2026
- **Also known as:** GHSA-8h6x-h86x-75wh, GO-2026-6559, MINI-2vfc-h8cx-37mf, MINI-3f4c-j9q7-w237, MINI-8chp-jjg3-w427, MINI-g6vc-pp62-qgpw, MINI-hchw-f528-v97m, MINI-v9hm-c66w-7v8j

## What is CVE-2026-77322?

CVE-2026-77322 is a high-severity denial of service vulnerability in emiago sipgo, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SIPGO is a library for writing SIP services in the GO language. Prior to 1.4.3, WSConnection.Read in sip/transport_ws.go creates a wsutil.Reader without setting MaxFrameSize, allowing NextFrame to accept a client-controlled header.Length before ParseMaxMessageLength is applied. An unauthenticated WS or WSS peer can send a frame header declaring an extremely large payload, causing an oversized allocation or a makeslice length panic before the payload is read and crashing or exhausting memory in the server process. This issue is fixed in version 1.4.3.

Weakness: CWE-789 (Memory Allocation with Excessive Size Value)

## Which versions are affected by CVE-2026-77322?

3 open source packages ship an affected version, including github.com/emiago/sipgo.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/emiago/sipgo` | Go | All versions | 1.4.3 |
| `github.com/emiago/sipgo` | Go | All versions | 1.4.3 |
| `github.com/emiago/sipgo` | Go | All versions | 1.4.3 |

## How do I fix CVE-2026-77322?

Upgrade github.com/emiago/sipgo to 1.4.3 or later.

## Is CVE-2026-77322 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-77322 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77322 and fix it if it is affected.

What it is: CVE-2026-77322 is a high-severity denial of service vulnerability in emiago sipgo, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-77322 exists.

Affected packages and fixed versions:
- github.com/emiago/sipgo (Go): affected all versions; fixed in 1.4.3
- github.com/emiago/sipgo (Go): affected all versions; fixed in 1.4.3
- github.com/emiago/sipgo (Go): affected all versions; fixed in 1.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77322/ (Markdown: https://insights.sbomify.com/CVE-2026-77322/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77322
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77322
- OSV: https://osv.dev/vulnerability/CVE-2026-77322

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77322/
Summaries are generated and may contain mistakes; the official description above is the record.
