# CVE-2026-77337: CakePHP: Potential Authentication bypass with CookieAuthenticator

> Attackers can bypass authentication and cause resource exhaustion by exploiting forgeable legacy tokens in the CakePHP CookieAuthenticator.

- **Severity:** Critical 9.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 24 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-77337, GHSA-h7xh-9h2x-2m37, UBUNTU-CVE-2026-77337

## What is CVE-2026-77337?

CVE-2026-77337 is a critical authentication bypass vulnerability in cakephp authentication, published on 24 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CakePHP Authentication is an authentication plugin for CakePHP that can also be used in PSR-7 based applications. Versions before 2.11.2, from 3.0.0 through 3.3.6, and from 4.0.0 through 4.2.0 allow authentication bypass and potential CPU or memory exhaustion when CookieAuthenticator uses unencrypted, forgeable legacy tokens. This issue is fixed in versions 2.11.2, 3.3.7, and 4.2.1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2026-77337?


## How do I fix CVE-2026-77337?

No fix has been published for CVE-2026-77337 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-77337 being exploited?

There is no known exploitation of CVE-2026-77337 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77337 and fix it if it is affected.

What it is: CVE-2026-77337 is a critical authentication bypass vulnerability in cakephp authentication, published on 24 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-77337 in the wild and no public exploit code.

Affected product: cakephp authentication. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77337/ (Markdown: https://insights.sbomify.com/CVE-2026-77337/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77337
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77337
- OSV: https://osv.dev/vulnerability/CVE-2026-77337

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77337/
Summaries are generated and may contain mistakes; the official description above is the record.
