CVE-2026-7735 osrg GoBGP AIGP Attribute bgp.go PathAttributeAigp.DecodeFromBytes buffer overflow

Medium 6.9 Published Updated

A buffer overflow in the GoBGP library's AIGP attribute parser allows remote attackers to execute arbitrary code or cause a denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-7735?

CVE-2026-7735 is a medium-severity memory corruption vulnerability in osrg GoBGP, published on 4 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A vulnerability was found in osrg GoBGP up to 4.3.0. Affected is the function PathAttributeAigp.DecodeFromBytes of the file pkg/packet/bgp/bgp.go of the component AIGP Attribute Parser. Performing a manipulation results in buffer overflow. It is possible to initiate the attack remotely. Upgrading to version 4.4.0 is able to address this issue. The patch is named 51ad1ada06cb41ce47b7066799981816f50b7ced. The affected component should be upgraded.

Weakness: CWE-120, CWE-119

Which versions are affected by CVE-2026-7735?

It affects 1 product.

Products include Osrg Gobgp.

How do I fix CVE-2026-7735?

Upgrade to a fixed version.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2026-7735 being exploited?

There is no known exploitation of CVE-2026-7735 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-7735, GHSA-5jvq-55xj-6qff, UBUNTU-CVE-2026-7735.

Is CVE-2026-7735 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free