# CVE-2026-77352: Wallos: Authenticated SSRF via per-user SMTP notification host (low-privilege user)

> Authenticated users can trigger server-side requests to internal networks via SMTP settings, potentially exposing internal services.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 31 Aug 2026
- **Updated:** 1 Sep 2026
- **Also known as:** GHSA-c75x-9vj6-57qj

## What is CVE-2026-77352?

CVE-2026-77352 is a medium-severity server-side request forgery vulnerability in ellite Wallos, published on 31 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Wallos is an open-source, self-hostable personal subscription tracker. From version 2.0.0 to before version 5.0.0, any authenticated Wallos user (no admin rights required) can make the server open arbitrary outbound SMTP connections to internal/link-local addresses, by setting the SMTP host of their personal email notifications to an internal IP. The per-user notification settings endpoint (endpoints/notifications/saveemailnotifications.php) performs no SSRF validation, and the notification cron (endpoints/cronjobs/sendnotifications.php) feeds that user-controlled host straight into PHPMailer ($mail->Host = $email['smtpAddress']). When the user's subscription notification fires, the server connects to the chosen host:port. This issue has been patched in version 5.0.0.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-77352?


## How do I fix CVE-2026-77352?

No fix has been published for CVE-2026-77352 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-77352 being exploited?

There is no known exploitation of CVE-2026-77352 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77352 and fix it if it is affected.

What it is: CVE-2026-77352 is a medium-severity server-side request forgery vulnerability in ellite Wallos, published on 31 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-77352 in the wild and no public exploit code.

Affected product: ellite Wallos. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77352/ (Markdown: https://insights.sbomify.com/CVE-2026-77352/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77352
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77352
- OSV: https://osv.dev/vulnerability/CVE-2026-77352

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77352/
Summaries are generated and may contain mistakes; the official description above is the record.
