# CVE-2026-77354: kin-openapi: Uncontrolled resource consumption in openapi3filter deepObject query parameter decoding

> An unauthenticated attacker can cause a denial of service via memory exhaustion by sending crafted deepObject query parameters to applications using kin-openapi.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-77354, GHSA-xhj3-7xw9-vr34, GO-2026-6275, MINI-22x7-qjhx-q5rf, MINI-2h49-f852-972x, MINI-2hmc-6xwq-7pg7, MINI-2jf6-cx8c-cjrq, MINI-35h5-hvx5-jcw7, MINI-42vg-63pm-25p4, MINI-4f7j-838x-88w8, MINI-54c2-4qqq-c2hj, MINI-58vh-m7qw-82gm, MINI-5mv9-m3h7-qjxr, MINI-6pr9-9g84-hr2r, MINI-8657-67rq-2pcc, MINI-c7hc-vgqx-6xgj, MINI-ccxc-vwmv-4cgh, MINI-cf7v-3j7x-8jwh, MINI-g5mq-c45m-34wv, MINI-g5wp-p3gf-8464, MINI-g7rc-jxm3-37x5, MINI-gc93-gw6x-jrjj, MINI-gwg9-q596-g4rc, MINI-gxwr-h9h8-9xgj, MINI-h46f-m4xv-76w3, MINI-h4p5-5cjf-33c7, MINI-h4pm-55hj-xwg4, MINI-hcvm-x3w7-gph8, MINI-hgq2-px9j-jfh7, MINI-hhx8-5rcp-hrx9, MINI-hm55-336f-wp7p, MINI-j5mj-r63f-fgxc, MINI-jmvh-rv58-qvgr, MINI-m3q8-qcw3-6266, MINI-mc6c-gc89-3c5f, MINI-mjgq-hq63-4469, MINI-mmcc-rx8p-xjgr, MINI-mvf8-8244-2cj3, MINI-p44p-4rxx-r723, MINI-p7j5-4w4p-46qh, MINI-p9m3-wr24-p7w6, MINI-pm9g-fcgf-qw4w, MINI-q99f-5g88-g5ff, MINI-qm29-7grq-qxr7, MINI-vvxr-qq9m-w3qr, MINI-w8vp-4gcc-mjc2, UBUNTU-CVE-2026-77354

## What is CVE-2026-77354?

CVE-2026-77354 is a high-severity denial of service vulnerability in getkin kin-openapi, published on 21 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

kin-openapi is a Go project for handling OpenAPI files. From 0.124.0 until 0.142.0, openapi3filter.sliceMapToSlice in openapi3filter/req_resp_decoder.go converts attacker-controlled sparse indexes from a deepObject query parameter into a dense slice by allocating entries from zero through the largest supplied index, after which buildResObj creates another slice of the same length. This allocation occurs before schema validation, so maxItems does not prevent it. An unauthenticated client can send a small query such as param[items][50000000]=x to an endpoint whose deepObject schema contains an array, forcing multi-gigabyte heap allocation and causing an OOM kill or restart loop. Other request-body encodings and styled parameters that do not produce bracketed integer indexes are not affected. This issue is fixed in version 0.142.0.

Weakness: CWE-789 (Memory Allocation with Excessive Size Value), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-77354?

3 open source packages ship an affected version, including github.com/getkin/kin-openapi.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/getkin/kin-openapi` | Go | From 0.124.0 | 0.142.0 |
| `github.com/getkin/kin-openapi` | Go | From 0.124.0 | 0.142.0 |
| `github.com/getkin/kin-openapi` | Go | From 0.124.0 | 0.142.0 |

## How do I fix CVE-2026-77354?

Upgrade github.com/getkin/kin-openapi to 0.142.0 or later.

## Is CVE-2026-77354 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-77354 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77354 and fix it if it is affected.

What it is: CVE-2026-77354 is a high-severity denial of service vulnerability in getkin kin-openapi, published on 21 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-77354 exists.

Affected packages and fixed versions:
- github.com/getkin/kin-openapi (Go): affected from 0.124.0; fixed in 0.142.0
- github.com/getkin/kin-openapi (Go): affected from 0.124.0; fixed in 0.142.0
- github.com/getkin/kin-openapi (Go): affected from 0.124.0; fixed in 0.142.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77354/ (Markdown: https://insights.sbomify.com/CVE-2026-77354/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77354
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77354
- OSV: https://osv.dev/vulnerability/CVE-2026-77354

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77354/
Summaries are generated and may contain mistakes; the official description above is the record.
