{"answers":{"affected":"3 open source packages ship an affected version, including github.com/osrg/gobgp/v4. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-7736 in the wild and no public exploit code.","fix":"Upgrade github.com/osrg/gobgp/v4 to 4.4.0 or later.","what":"CVE-2026-7736 is a medium-severity vulnerability in osrg GoBGP, published on 4 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-7736 and fix it if it is affected.\n\nWhat it is: CVE-2026-7736 is a medium-severity vulnerability in osrg GoBGP, published on 4 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-7736 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/osrg/gobgp/v4 (Go): affected all versions; fixed in 4.4.0\n- github.com/osrg/gobgp/v4 (Go): affected all versions; fixed in 4.4.0\n- github.com/osrg/gobgp/v4 (Go): affected all versions; fixed in 4.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-7736/ (Markdown: https://insights.sbomify.com/CVE-2026-7736/index.md)","id":"CVE-2026-7736","markdown":"https://insights.sbomify.com/CVE-2026-7736/index.md","name":"CVE-2026-7736","record":{"aliases":["DEBIAN-CVE-2026-7736","GHSA-hj4w-qr9j-c4cf","GO-2026-5427","UBUNTU-CVE-2026-7736"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"GoBGP library","requires_auth":"none","summary":"Remote attackers can trigger an integer underflow in GoBGP's MRT parser, potentially causing a denial of service.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"gobgp","vendor":"osrg"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X","version":"4.0"},"cwes":[{"id":"CWE-191","name":"Integer Underflow (Wrap or Wraparound)"},{"id":"CWE-189","name":null}],"description":"A vulnerability was determined in osrg GoBGP up to 4.3.0. Affected by this vulnerability is the function parseRibEntry of the file pkg/packet/mrt/mrt.go. Executing a manipulation can lead to integer underflow. It is possible to launch the attack remotely. Upgrading to version 4.4.0 addresses this issue. This patch is called 76d911046344a3923cbe573364197aa081944592. It is suggested to upgrade the affected component.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"osrg GoBGP mrt.go parseRibEntry integer underflow","id":"CVE-2026-7736","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"integer_overflow","year":"2026"},"n_packages":3,"n_references":6,"next":{"headline":"osrg GoBGP BMP Parser bmp.go BMPStatisticsReport.ParseBody out-of-bounds","id":"CVE-2026-7737"},"packages":[{"ecosystem":"Go","fixed":["4.4.0"],"introduced":["0"],"last_affected":[],"package":"github.com/osrg/gobgp/v4","purl":null,"source":"GHSA-hj4w-qr9j-c4cf"},{"ecosystem":"Go","fixed":["4.4.0"],"introduced":["0"],"last_affected":[],"package":"github.com/osrg/gobgp/v4","purl":"pkg:golang/github.com/osrg/gobgp/v4","source":"GHSA-hj4w-qr9j-c4cf"},{"ecosystem":"Go","fixed":["4.4.0"],"introduced":["0"],"last_affected":[],"package":"github.com/osrg/gobgp/v4","purl":"pkg:golang/github.com/osrg/gobgp/v4","source":"GO-2026-5427"}],"prev":{"headline":"osrg GoBGP AIGP Attribute bgp.go PathAttributeAigp.DecodeFromBytes buffer overflow","id":"CVE-2026-7735"},"products":["GoBGP"],"published":"2026-05-04","related":[{"cvss_score":8.6,"headline":"GoBGP panics due to a zero value for softwareVersionLen","id":"CVE-2025-43971","kev_date_added":null,"published":"2025-04-21"},{"cvss_score":7.5,"headline":"GoBGP: Remote Denial of Service (Panic) via Malformed Well-known Path Attribute","id":"CVE-2026-41642","kev_date_added":null,"published":"2026-05-07"},{"cvss_score":7.5,"headline":"GoBGP: Remote Denial of Service (Panic) in UpdatePathAttrs4ByteAs via Malformed BGP UPDATE","id":"CVE-2026-41643","kev_date_added":null,"published":"2026-05-07"},{"cvss_score":7.5,"headline":"GoBGP: Panic in AdjRib.Update via malformed BGP Update message (Nil Pointer Dereference)","id":"CVE-2026-42285","kev_date_added":null,"published":"2026-05-07"},{"cvss_score":7.5,"headline":"GoBGP has an out-of-bounds read in the ParseIP6Extended function","id":"CVE-2026-37461","kev_date_added":null,"published":"2026-05-04"},{"cvss_score":7.5,"headline":"GoBGP vulnerable to a denial of service via the NEXT_HOP path attribute","id":"CVE-2026-30405","kev_date_added":null,"published":"2026-03-16"},{"cvss_score":6.9,"headline":"osrg GoBGP SRv6 L3 Service prefix_sid.go SRv6L3ServiceAttribute.DecodeFromBytes denial of service","id":"CVE-2026-7734","kev_date_added":null,"published":"2026-05-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-04","vendors":["osrg"]},"summary":"Remote attackers can trigger an integer underflow in GoBGP's MRT parser, potentially causing a denial of service.","url":"https://insights.sbomify.com/CVE-2026-7736/"}