# CVE-2026-7736: osrg GoBGP mrt.go parseRibEntry integer underflow

> Remote attackers can trigger an integer underflow in GoBGP's MRT parser, potentially causing a denial of service.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 May 2026
- **Updated:** 4 May 2026
- **Also known as:** DEBIAN-CVE-2026-7736, GHSA-hj4w-qr9j-c4cf, GO-2026-5427, UBUNTU-CVE-2026-7736

## What is CVE-2026-7736?

CVE-2026-7736 is a medium-severity vulnerability in osrg GoBGP, published on 4 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability was determined in osrg GoBGP up to 4.3.0. Affected by this vulnerability is the function parseRibEntry of the file pkg/packet/mrt/mrt.go. Executing a manipulation can lead to integer underflow. It is possible to launch the attack remotely. Upgrading to version 4.4.0 addresses this issue. This patch is called 76d911046344a3923cbe573364197aa081944592. It is suggested to upgrade the affected component.

Weakness: CWE-191 (Integer Underflow (Wrap or Wraparound)), CWE-189

## Which versions are affected by CVE-2026-7736?

3 open source packages ship an affected version, including github.com/osrg/gobgp/v4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/osrg/gobgp/v4` | Go | All versions | 4.4.0 |
| `github.com/osrg/gobgp/v4` | Go | All versions | 4.4.0 |
| `github.com/osrg/gobgp/v4` | Go | All versions | 4.4.0 |

Products: Osrg Gobgp.

## How do I fix CVE-2026-7736?

Upgrade github.com/osrg/gobgp/v4 to 4.4.0 or later.

## Is CVE-2026-7736 being exploited?

There is no known exploitation of CVE-2026-7736 in the wild and no public exploit code.

## Other vulnerabilities in osrg GoBGP

- [CVE-2025-43971](https://insights.sbomify.com/CVE-2025-43971/): GoBGP panics due to a zero value for softwareVersionLen (high 8.6)
- [CVE-2026-41642](https://insights.sbomify.com/CVE-2026-41642/): GoBGP: Remote Denial of Service (Panic) via Malformed Well-known Path Attribute (high 7.5)
- [CVE-2026-41643](https://insights.sbomify.com/CVE-2026-41643/): GoBGP: Remote Denial of Service (Panic) in UpdatePathAttrs4ByteAs via Malformed BGP UPDATE (high 7.5)
- [CVE-2026-42285](https://insights.sbomify.com/CVE-2026-42285/): GoBGP: Panic in AdjRib.Update via malformed BGP Update message (Nil Pointer Dereference) (high 7.5)
- [CVE-2026-37461](https://insights.sbomify.com/CVE-2026-37461/): GoBGP has an out-of-bounds read in the ParseIP6Extended function (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-7736 and fix it if it is affected.

What it is: CVE-2026-7736 is a medium-severity vulnerability in osrg GoBGP, published on 4 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-7736 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/osrg/gobgp/v4 (Go): affected all versions; fixed in 4.4.0
- github.com/osrg/gobgp/v4 (Go): affected all versions; fixed in 4.4.0
- github.com/osrg/gobgp/v4 (Go): affected all versions; fixed in 4.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-7736/ (Markdown: https://insights.sbomify.com/CVE-2026-7736/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-7736
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-7736
- OSV: https://osv.dev/vulnerability/CVE-2026-7736

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-7736/
Summaries are generated and may contain mistakes; the official description above is the record.
