# CVE-2026-77360: oRPC: Vary Header Injection in CORS Plugin leading to potential Cache/CORS Bypass

> Attackers can inject Vary headers to pollute cache keys and bypass CORS enforcement in cached deployments of the oRPC server library.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** GHSA-j9v4-rhgr-4m5f

## What is CVE-2026-77360?

CVE-2026-77360 is a medium-severity vulnerability in middleapi orpc, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

oRPC is an tool that helps build APIs that are end-to-end type-safe and adhere to OpenAPI standards. Prior to 1.14.8, the @orpc/server CORS plugin in packages/server/src/plugins/cors.ts copies a client's incoming Vary request header into the response instead of controlling Vary as a response-only header and using Origin for request-origin variation. In deployments behind a shared cache, CDN, or reverse proxy that keys responses using Vary, a client can inject arbitrary variation values, pollute cache keys, and cause inconsistent CORS enforcement for other clients. Default non-cached configurations have no established direct confidentiality, integrity, or availability impact. This issue is fixed in version 1.14.8.

Weakness: CWE-113 (Improper Neutralization of CRLF Sequences in HTTP Headers)

## Which versions are affected by CVE-2026-77360?

2 open source packages ship an affected version, including @orpc/server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@orpc/server` | npm | All versions | 1.14.8 |
| `@orpc/server` | npm | All versions | 1.14.8 |

## How do I fix CVE-2026-77360?

Upgrade @orpc/server to 1.14.8 or later.

## Is CVE-2026-77360 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-77360 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77360 and fix it if it is affected.

What it is: CVE-2026-77360 is a medium-severity vulnerability in middleapi orpc, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-77360 exists.

Affected packages and fixed versions:
- @orpc/server (npm): affected all versions; fixed in 1.14.8
- @orpc/server (npm): affected all versions; fixed in 1.14.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77360/ (Markdown: https://insights.sbomify.com/CVE-2026-77360/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77360
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77360
- OSV: https://osv.dev/vulnerability/CVE-2026-77360

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77360/
Summaries are generated and may contain mistakes; the official description above is the record.
