# CVE-2026-77362: obsidian-tc bridge tools expose data outside the read ACL

> An authenticated attacker can read data from notes outside their permitted access control list via bridge tools in the obsidian-tc server.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Oct 2026
- **Updated:** 13 Oct 2026
- **Also known as:** GHSA-43r2-c7g8-prc8

## What is CVE-2026-77362?

CVE-2026-77362 is a medium-severity missing authorization vulnerability in The-40-Thieves obsidian-tc, published on 13 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

obsidian-tc is a governed, agent-ready Model Context Protocol server for Obsidian vaults. Prior to 1.3.1, bridge tools do not consistently apply the read access-control list (ACL) to every returned field. The tasks_filter tool exposes group counts derived from denied notes, makemd_query passes unfiltered sibling result fields through, and list_templates exposes template paths and parsed user-function bodies without a read-whitelist check. An authenticated caller can consequently infer or read data from notes outside the caller's read ACL. Version 1.3.1 fixes the vulnerability by filtering path-attributable fields and applying the read whitelist to list_templates.

Weakness: CWE-863 (Incorrect Authorization), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-77362?

2 open source packages ship an affected version, including obsidian-tc.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `obsidian-tc` | npm | All versions | 1.3.1 |
| `obsidian-tc` | npm | All versions | 1.3.1 |

## How do I fix CVE-2026-77362?

Upgrade obsidian-tc to 1.3.1 or later.

## Is CVE-2026-77362 being exploited?

There is no known exploitation of CVE-2026-77362 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77362 and fix it if it is affected.

What it is: CVE-2026-77362 is a medium-severity missing authorization vulnerability in The-40-Thieves obsidian-tc, published on 13 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-77362 in the wild and no public exploit code.

Affected packages and fixed versions:
- obsidian-tc (npm): affected all versions; fixed in 1.3.1
- obsidian-tc (npm): affected all versions; fixed in 1.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77362/ (Markdown: https://insights.sbomify.com/CVE-2026-77362/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77362
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77362
- OSV: https://osv.dev/vulnerability/CVE-2026-77362

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77362/
Summaries are generated and may contain mistakes; the official description above is the record.
