# CVE-2026-77364: obsidian-tc fail-open default ACL exposes Obsidian control-directory secrets

> An authenticated attacker can read sensitive control directory files, exposing secrets like API keys and passwords, due to fail-open default ACLs.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Oct 2026
- **Updated:** 15 Oct 2026
- **Also known as:** GHSA-cvp8-vvgf-69q4

## What is CVE-2026-77364?

CVE-2026-77364 is a medium-severity missing authorization vulnerability in The-40-Thieves obsidian-tc, published on 12 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

obsidian-tc is a governed, agent-ready Model Context Protocol server for Obsidian vaults. Prior to 1.3.1, undefined readPaths and writePaths settings allow all paths, strictReadDefault does not protect direct requests, and the .obsidian, .git, and .trash control directories are excluded only during enumeration. An authenticated caller can directly read sensitive files such as .obsidian/plugins/*/data.json, potentially exposing plugin API keys, Obsidian Sync passwords, and other in-vault data. Version 1.3.1 fixes the vulnerability by denying the control directories by default and enforcing strictReadDefault on direct request paths.

Weakness: CWE-276 (Incorrect Default Permissions), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-77364?

2 open source packages ship an affected version, including obsidian-tc.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `obsidian-tc` | npm | All versions | 1.3.1 |
| `obsidian-tc` | npm | All versions | 1.3.1 |

## How do I fix CVE-2026-77364?

Upgrade obsidian-tc to 1.3.1 or later.

## Is CVE-2026-77364 being exploited?

There is no known exploitation of CVE-2026-77364 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77364 and fix it if it is affected.

What it is: CVE-2026-77364 is a medium-severity missing authorization vulnerability in The-40-Thieves obsidian-tc, published on 12 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-77364 in the wild and no public exploit code.

Affected packages and fixed versions:
- obsidian-tc (npm): affected all versions; fixed in 1.3.1
- obsidian-tc (npm): affected all versions; fixed in 1.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77364/ (Markdown: https://insights.sbomify.com/CVE-2026-77364/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77364
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77364
- OSV: https://osv.dev/vulnerability/CVE-2026-77364

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77364/
Summaries are generated and may contain mistakes; the official description above is the record.
