# CVE-2026-77366: obsidian-tc tokens can access arbitrary configured vaults

> Attackers with valid tokens can access arbitrary Obsidian vaults to read, write, or delete data due to missing vault binding checks.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Oct 2026
- **Updated:** 13 Oct 2026
- **Also known as:** GHSA-84c9-qqpq-2pq5

## What is CVE-2026-77366?

CVE-2026-77366 is a critical missing authorization vulnerability in The-40-Thieves obsidian-tc, published on 12 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

obsidian-tc is a governed, agent-ready Model Context Protocol server for Obsidian vaults. Prior to 1.3.1, tool dispatch does not compare the caller-controlled input.vault value with the vault bound to the caller, the JSON Web Token (JWT) has no vault claim, and the folder access-control list is shared globally. Any valid token can therefore select another configured vault and read, write, or delete its contents through affected tools. Version 1.3.1 fixes the vulnerability by binding tokens and request context to a vault and rejecting mismatched input.vault values before scope checks.

Weakness: CWE-863 (Incorrect Authorization), CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-77366?

2 open source packages ship an affected version, including obsidian-tc.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `obsidian-tc` | npm | All versions | 1.3.1 |
| `obsidian-tc` | npm | All versions | 1.3.1 |

## How do I fix CVE-2026-77366?

Upgrade obsidian-tc to 1.3.1 or later.

## Is CVE-2026-77366 being exploited?

There is no known exploitation of CVE-2026-77366 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77366 and fix it if it is affected.

What it is: CVE-2026-77366 is a critical missing authorization vulnerability in The-40-Thieves obsidian-tc, published on 12 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-77366 in the wild and no public exploit code.

Affected packages and fixed versions:
- obsidian-tc (npm): affected all versions; fixed in 1.3.1
- obsidian-tc (npm): affected all versions; fixed in 1.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77366/ (Markdown: https://insights.sbomify.com/CVE-2026-77366/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77366
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77366
- OSV: https://osv.dev/vulnerability/CVE-2026-77366

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77366/
Summaries are generated and may contain mistakes; the official description above is the record.
