{"answers":{"affected":"3 open source packages ship an affected version, including geopy.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-77387 exists.","fix":"Upgrade geopy to 2.5.0 or later.","what":"CVE-2026-77387 is a medium-severity denial of service vulnerability in geopy, published on 1 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-77387 and fix it if it is affected.\n\nWhat it is: CVE-2026-77387 is a medium-severity denial of service vulnerability in geopy, published on 1 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-77387 exists.\n\nAffected packages and fixed versions:\n- geopy (PyPI): affected all versions; fixed in 2.5.0\n- geopy (PyPI): affected all versions; fixed in 2.5.0\n- geopy (PyPI): affected all versions; fixed in 2.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-77387/ (Markdown: https://insights.sbomify.com/CVE-2026-77387/index.md)","id":"CVE-2026-77387","markdown":"https://insights.sbomify.com/CVE-2026-77387/index.md","name":"CVE-2026-77387","record":{"aliases":["CLEANSTART-2026-QB35477","DEBIAN-CVE-2026-77387","ECHO-028b-f7e1-fcde","GHSA-mhvh-fq92-pfmr","PYSEC-2026-4218","UBUNTU-CVE-2026-77387","openSUSE-SU-2026:11724-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python geocoding library","requires_auth":"none","summary":"An attacker can cause a denial of service in applications using geopy by sending long malformed coordinate strings that trigger inefficient regular expression processing.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"geopy is a geocoding library for Python. Prior to 2.5.0, geopy.Point and Point.from_string() can spend excessive CPU time due to inefficient regular-expression behavior when an application passes a long malformed coordinate string without the 256-character input limit used by the fix. Geocoder reverse methods also reach the vulnerable parsing path when called with string inputs. Repeated attacker-controlled requests can cause a denial of service, while the numeric Point constructor is unaffected. This issue is fixed in version 2.5.0.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"geopy: Regular Expression Denial of Service (ReDoS) in geopy.Point","id":"CVE-2026-77387","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":4,"n_references":5,"next":{"headline":"SourceCodester Dynamic Input Field Generator Using HTML, CSS, and PHP cross-site request forgery","id":"CVE-2026-77391"},"packages":[{"ecosystem":"PyPI","fixed":["2.5.0"],"introduced":["0"],"last_affected":[],"package":"geopy","purl":null,"source":"GHSA-mhvh-fq92-pfmr"},{"ecosystem":"PyPI","fixed":["2.5.0"],"introduced":["0"],"last_affected":[],"package":"geopy","purl":"pkg:pypi/geopy","source":"GHSA-mhvh-fq92-pfmr"},{"ecosystem":"PyPI","fixed":["2.5.0"],"introduced":["0"],"last_affected":[],"package":"geopy","purl":"pkg:pypi/geopy","source":"PYSEC-2026-4218"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.5.0-1.1"],"introduced":["0"],"last_affected":[],"package":"python-geopy","purl":"pkg:rpm/opensuse/python-geopy\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:11724-1"}],"prev":{"headline":"Kyoo: OIDC login token can be redirected to an attacker-controlled URL","id":"CVE-2026-77386"},"products":["geopy"],"published":"2026-10-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-01","vendors":["geopy"]},"summary":"An attacker can cause a denial of service in applications using geopy by sending long malformed coordinate strings that trigger inefficient regular expression processing.","url":"https://insights.sbomify.com/CVE-2026-77387/"}