# CVE-2026-77387: geopy: Regular Expression Denial of Service (ReDoS) in geopy.Point

> An attacker can cause a denial of service in applications using geopy by sending long malformed coordinate strings that trigger inefficient regular expression processing.

- **Severity:** Medium 4.0 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Oct 2026
- **Updated:** 1 Oct 2026
- **Also known as:** CLEANSTART-2026-QB35477, DEBIAN-CVE-2026-77387, ECHO-028b-f7e1-fcde, GHSA-mhvh-fq92-pfmr, PYSEC-2026-4218, UBUNTU-CVE-2026-77387, openSUSE-SU-2026:11724-1

## What is CVE-2026-77387?

CVE-2026-77387 is a medium-severity denial of service vulnerability in geopy, published on 1 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

geopy is a geocoding library for Python. Prior to 2.5.0, geopy.Point and Point.from_string() can spend excessive CPU time due to inefficient regular-expression behavior when an application passes a long malformed coordinate string without the 256-character input limit used by the fix. Geocoder reverse methods also reach the vulnerable parsing path when called with string inputs. Repeated attacker-controlled requests can cause a denial of service, while the numeric Point constructor is unaffected. This issue is fixed in version 2.5.0.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-77387?

3 open source packages ship an affected version, including geopy.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `geopy` | PyPI | All versions | 2.5.0 |
| `geopy` | PyPI | All versions | 2.5.0 |
| `geopy` | PyPI | All versions | 2.5.0 |
| `python-geopy` | openSUSE:Tumbleweed | All versions | 2.5.0-1.1 |

## How do I fix CVE-2026-77387?

Upgrade geopy to 2.5.0 or later.

## Is CVE-2026-77387 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-77387 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77387 and fix it if it is affected.

What it is: CVE-2026-77387 is a medium-severity denial of service vulnerability in geopy, published on 1 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-77387 exists.

Affected packages and fixed versions:
- geopy (PyPI): affected all versions; fixed in 2.5.0
- geopy (PyPI): affected all versions; fixed in 2.5.0
- geopy (PyPI): affected all versions; fixed in 2.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77387/ (Markdown: https://insights.sbomify.com/CVE-2026-77387/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77387
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77387
- OSV: https://osv.dev/vulnerability/CVE-2026-77387

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77387/
Summaries are generated and may contain mistakes; the official description above is the record.
