# CVE-2026-77404: RabbitMQ amqp091-go: Connection Configuration Overwrite via Unsanitized TLS Path Parameter Injection

> Attackers can inject delimiters into TLS paths to overwrite connection options, potentially selecting unintended cryptographic assets or corrupting configuration.

- **Severity:** High 8.7 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** CLEANSTART-2026-OF14206, CLEANSTART-2026-PW36869, CLEANSTART-2026-TU13335, DEBIAN-CVE-2026-77404, ECHO-b336-8e7c-32ba, GHSA-465g-fh3v-9jw4, GO-2026-6493, MINI-28wf-jqj4-w428, MINI-3hr4-h8hh-cghr, MINI-4x2r-hx7r-x6v7, MINI-4xwr-v243-mvj2, MINI-5ppc-82cw-j4p7, MINI-5q98-m5r5-7ghh, MINI-67rr-whcm-99wm, MINI-6gmx-qp44-h5x4, MINI-6p2m-c86v-rgq6, MINI-6qgw-j3gx-4mxw, MINI-8fmx-xj8m-p3mc, MINI-9mpw-cfgr-vwfm, MINI-9x26-84hj-mcp8, MINI-cfc5-wg65-gx7w, MINI-cmr9-4v7p-95gw, MINI-cqc7-9cjm-pwf5, MINI-f3cw-h665-7532, MINI-f826-hrr3-hwgr, MINI-g2x9-c3c6-j5ff, MINI-gr93-387f-hgx3, MINI-h6x9-89rc-qfgx, MINI-hwph-j427-ghc2, MINI-j2hq-hvrv-6394, MINI-m2gw-jmh2-hwqc, MINI-m6fx-chwg-qwwc, MINI-m789-hvw8-8crc, MINI-mcfv-fp66-6pwc, MINI-qjvv-f65w-5p88, MINI-rjmw-96pr-h4vx, MINI-rxwc-x7g6-96vx, MINI-v9cj-rrcv-jhpq, MINI-vh69-mrr6-grm9, MINI-vw85-g676-6gf8, MINI-x4xq-7jhx-ph35, MINI-x97g-5qmj-2pcf, MINI-xw47-gp9r-cch4, ROOT-APP-GOBINARY-CVE-2026-77404, UBUNTU-CVE-2026-77404

## What is CVE-2026-77404?

CVE-2026-77404 is a high-severity vulnerability in rabbitmq amqp091-go, published on 16 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

RabbitMQ amqp091-go is a Go AMQP 0.9.1 client. Prior to 1.13.0, URI.String in uri.go concatenates CertFile, KeyFile, CACertFile, and ServerName values directly into an AMQPS query string instead of encoding them as URL query parameters with url.Values. If an application accepts a TLS asset path containing ampersand or equals delimiters and later reparses the serialized URI with ParseURI, the embedded delimiters can create or overwrite connection options, including paths to TLS certificate, key, or CA files. This can corrupt connection configuration or select unintended local cryptographic assets. This issue is fixed in version 1.13.0.

Weakness: CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-77404?

3 open source packages ship an affected version, including github.com/rabbitmq/amqp091-go.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/rabbitmq/amqp091-go` | Go | All versions | 1.13.0 |
| `github.com/rabbitmq/amqp091-go` | Go | All versions | 1.13.0 |
| `github.com/rabbitmq/amqp091-go` | Go | All versions | 1.13.0 |

## How do I fix CVE-2026-77404?

Upgrade github.com/rabbitmq/amqp091-go to 1.13.0 or later.

## Is CVE-2026-77404 being exploited?

There is no known exploitation of CVE-2026-77404 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77404 and fix it if it is affected.

What it is: CVE-2026-77404 is a high-severity vulnerability in rabbitmq amqp091-go, published on 16 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-77404 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/rabbitmq/amqp091-go (Go): affected all versions; fixed in 1.13.0
- github.com/rabbitmq/amqp091-go (Go): affected all versions; fixed in 1.13.0
- github.com/rabbitmq/amqp091-go (Go): affected all versions; fixed in 1.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77404/ (Markdown: https://insights.sbomify.com/CVE-2026-77404/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77404
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77404
- OSV: https://osv.dev/vulnerability/CVE-2026-77404

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77404/
Summaries are generated and may contain mistakes; the official description above is the record.
