CVE-2026-77405 RabbitMQ amqp091-go: Missing Explicit TLS Minimum Version Configuration In URI Parser
A network attacker can force the use of obsolete TLS versions in RabbitMQ Go client connections, weakening transport security for messages and credentials.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-77405?
CVE-2026-77405 is a critical vulnerability in rabbitmq amqp091-go, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
RabbitMQ amqp091-go is a Go AMQP 0.9.1 client. Prior to 1.13.0, tlsConfigFromURI in uri.go creates tls.Config values without setting MinVersion to tls.VersionTLS12. Builds using a Go runtime whose default permits TLS 1.0 or TLS 1.1 can therefore negotiate an obsolete protocol version when connecting through an amqps URI. A network attacker able to influence TLS negotiation with such a legacy build may weaken transport protection for AMQP messages and credentials. This issue is fixed in version 1.13.0.
Weakness: CWE-326
Which versions are affected by CVE-2026-77405?
3 open source packages ship an affected version, including github.com/rabbitmq/amqp091-go.
| Package | Affected | Fixed in |
|---|---|---|
github.com/rabbitmq/amqp091-go Go | All versions | 1.13.0 |
github.com/rabbitmq/amqp091-go Go | All versions | 1.13.0 |
github.com/rabbitmq/amqp091-go Go | All versions | 1.13.0 |
How do I fix CVE-2026-77405?
Upgrade github.com/rabbitmq/amqp091-go to 1.13.0 or later.
Is CVE-2026-77405 being exploited?
There is no known exploitation of CVE-2026-77405 in the wild and no public exploit code.
Sources
Also known as AZL-103182, AZL-103284, CLEANSTART-2026-AD74285, CLEANSTART-2026-IH81544, CLEANSTART-2026-YB17201, DEBIAN-CVE-2026-77405 and 41 more.