# CVE-2026-77405: RabbitMQ amqp091-go: Missing Explicit TLS Minimum Version Configuration In URI Parser

> A network attacker can force the use of obsolete TLS versions in RabbitMQ Go client connections, weakening transport security for messages and credentials.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:H/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2026
- **Updated:** 18 Sep 2026
- **Also known as:** AZL-103182, AZL-103284, CLEANSTART-2026-AD74285, CLEANSTART-2026-IH81544, CLEANSTART-2026-YB17201, DEBIAN-CVE-2026-77405, ECHO-a09c-6884-56a4, GHSA-33mj-cw25-m34h, GO-2026-6492, MINI-28j4-fh65-5cjx, MINI-2gxj-rp96-wq3x, MINI-4q6w-h38g-42c2, MINI-4r77-w5vj-vj6f, MINI-5475-rr42-fqw8, MINI-5cj3-j478-5p2r, MINI-5h9c-68v9-rj6x, MINI-5m9v-gfqw-qfc8, MINI-5pgh-jfmw-hwv9, MINI-5rvg-9x2q-5fmv, MINI-668f-gr6m-jccv, MINI-7fpw-3c6v-6g9w, MINI-87fq-6xr2-jpjc, MINI-983m-w6x8-w66c, MINI-9mrq-whrp-fq2f, MINI-9wmw-2jvv-8hg8, MINI-f7mj-gv8f-j7f2, MINI-fp79-w8wj-fm9r, MINI-fr3g-7hrv-6vwh, MINI-fxfx-x659-9rw7, MINI-hjrr-hfrf-gmp6, MINI-j59g-67m2-g9g2, MINI-jcmp-6rwj-c7x8, MINI-jfgw-mf94-76jm, MINI-jwgf-ccgm-8cwh, MINI-m2f6-3mx4-cr9w, MINI-mwm5-946h-4p3c, MINI-q89p-3rf6-66c3, MINI-rwh4-rq7m-v8vm, MINI-v4fm-5qh9-qwpq, MINI-vggf-fw9w-vh3m, MINI-w4x6-h565-wgc3, MINI-wgcj-h363-75x8, MINI-wjwf-g8mh-93q7, MINI-xgg6-fjr2-64vg, MINI-xgwp-7r54-m5hq, ROOT-APP-GOBINARY-CVE-2026-77405, UBUNTU-CVE-2026-77405

## What is CVE-2026-77405?

CVE-2026-77405 is a critical vulnerability in rabbitmq amqp091-go, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

RabbitMQ amqp091-go is a Go AMQP 0.9.1 client. Prior to 1.13.0, tlsConfigFromURI in uri.go creates tls.Config values without setting MinVersion to tls.VersionTLS12. Builds using a Go runtime whose default permits TLS 1.0 or TLS 1.1 can therefore negotiate an obsolete protocol version when connecting through an amqps URI. A network attacker able to influence TLS negotiation with such a legacy build may weaken transport protection for AMQP messages and credentials. This issue is fixed in version 1.13.0.

Weakness: CWE-326 (Inadequate Encryption Strength)

## Which versions are affected by CVE-2026-77405?

3 open source packages ship an affected version, including github.com/rabbitmq/amqp091-go.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/rabbitmq/amqp091-go` | Go | All versions | 1.13.0 |
| `github.com/rabbitmq/amqp091-go` | Go | All versions | 1.13.0 |
| `github.com/rabbitmq/amqp091-go` | Go | All versions | 1.13.0 |

## How do I fix CVE-2026-77405?

Upgrade github.com/rabbitmq/amqp091-go to 1.13.0 or later.

## Is CVE-2026-77405 being exploited?

There is no known exploitation of CVE-2026-77405 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77405 and fix it if it is affected.

What it is: CVE-2026-77405 is a critical vulnerability in rabbitmq amqp091-go, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-77405 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/rabbitmq/amqp091-go (Go): affected all versions; fixed in 1.13.0
- github.com/rabbitmq/amqp091-go (Go): affected all versions; fixed in 1.13.0
- github.com/rabbitmq/amqp091-go (Go): affected all versions; fixed in 1.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77405/ (Markdown: https://insights.sbomify.com/CVE-2026-77405/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77405
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77405
- OSV: https://osv.dev/vulnerability/CVE-2026-77405

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77405/
Summaries are generated and may contain mistakes; the official description above is the record.
